Last Comment Bug 759976 - Remove JSDEBUGGER*
: Remove JSDEBUGGER*
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: mozilla15
Assigned To: :Benjamin Peterson
:
: Jason Orendorff [:jorendorff]
Mentors:
http://www.youtube.com/watch?v=mUP3A9...
Depends on: 759902
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 19:38 PDT by :Benjamin Peterson
Modified: 2012-06-01 08:11 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove it (2.99 KB, patch)
2012-05-30 19:39 PDT, :Benjamin Peterson
jorendorff: review+
Details | Diff | Splinter Review
kill all JSDEBUGGER stuff (3.56 KB, patch)
2012-05-31 10:20 PDT, :Benjamin Peterson
jorendorff: review+
Details | Diff | Splinter Review

Description :Benjamin Peterson 2012-05-30 19:38:10 PDT
Quoth Jason:
"JSDEBUGGER_C_UI? Gosh. We should just rip this stuff out. I don't know when it was last compiled by anyone anywhere."

I'm extending this to JSDEBUGGER_JAVA_UI, since that seems unused, too.
Comment 1 :Benjamin Peterson 2012-05-30 19:39:24 PDT
Created attachment 628573 [details] [diff] [review]
remove it
Comment 2 Jason Orendorff [:jorendorff] 2012-05-31 10:12:13 PDT
Comment on attachment 628573 [details] [diff] [review]
remove it

r=me. Please go ahead and extend this to all JSDEBUGGER stuff.
Comment 3 :Benjamin Peterson 2012-05-31 10:20:44 PDT
Created attachment 628789 [details] [diff] [review]
kill all JSDEBUGGER stuff
Comment 4 Jason Orendorff [:jorendorff] 2012-05-31 14:47:12 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/af60f15c49e1
Comment 5 Ed Morley [:emorley] 2012-06-01 08:11:39 PDT
https://hg.mozilla.org/mozilla-central/rev/af60f15c49e1

Note You need to log in before you can comment on or make changes to this bug.