Last Comment Bug 759997 - Factor out the three arms of SurfaceFromElement into separate functions
: Factor out the three arms of SurfaceFromElement into separate functions
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Boris Zbarsky [:bz] (Out June 25-July 6)
:
Mentors:
Depends on: 748266
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 22:24 PDT by Boris Zbarsky [:bz] (Out June 25-July 6)
Modified: 2012-06-02 11:58 PDT (History)
2 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Break out the three branches of SurfaceFromElement into separate functions so that we can call the one that matches the kind of element we have directly. (12.87 KB, patch)
2012-05-30 22:25 PDT, Boris Zbarsky [:bz] (Out June 25-July 6)
roc: review+
Details | Diff | Review

Description Boris Zbarsky [:bz] (Out June 25-July 6) 2012-05-30 22:24:36 PDT
With the new DOM bindings and overload resolution, we actually know coming in what sort of element we have, so there's no need to redetect it.
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-05-30 22:25:33 PDT
Created attachment 628601 [details] [diff] [review]
Break out the three branches of SurfaceFromElement into separate functions so that we can call the one that matches the kind of element we have directly.
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-05-31 11:36:01 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6a46906eb017
Comment 3 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-05-31 14:13:01 PDT
Backed out because I had to back out bug 748266.
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-06-01 09:48:34 PDT
And relanded: https://hg.mozilla.org/integration/mozilla-inbound/rev/aeca3790f053
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-02 11:58:45 PDT
https://hg.mozilla.org/mozilla-central/rev/aeca3790f053

Note You need to log in before you can comment on or make changes to this bug.