Last Comment Bug 760076 - Wrapper construct users Wrapper::GET rather than Wrapper::CALL
: Wrapper construct users Wrapper::GET rather than Wrapper::CALL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Bobby Holley (:bholley) (busy with Stylo)
:
Mentors:
Depends on:
Blocks: 756173
  Show dependency treegraph
 
Reported: 2012-05-31 05:42 PDT by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2012-06-01 08:41 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make |construct| use Wrapper::CALL. v1 (3.55 KB, patch)
2012-05-31 06:42 PDT, Bobby Holley (:bholley) (busy with Stylo)
mrbkap: review+
Details | Diff | Splinter Review

Description Bobby Holley (:bholley) (busy with Stylo) 2012-05-31 05:42:13 PDT
This makes no sense to me. It also means that COW-ed objects can be ()-ed but not new-ed.

This was the source of some nastiness over in bug 756173. I'll write up a patch right now.
Comment 1 Bobby Holley (:bholley) (busy with Stylo) 2012-05-31 06:42:26 PDT
Created attachment 628705 [details] [diff] [review]
Make |construct| use Wrapper::CALL. v1

Attaching a patch. Pushed to try here: https://tbpl.mozilla.org/?tree=Try&rev=4f003eaf3822

Flagging jorendorff for review in case he remembers some reason why it was supposed to be like this.
Comment 2 Blake Kaplan (:mrbkap) 2012-05-31 08:46:48 PDT
Comment on attachment 628705 [details] [diff] [review]
Make |construct| use Wrapper::CALL. v1

Stealing the review here as this was my fault... It looks like when I added the CALL permission during the brain transplant scramble, I simply forgot to update construct to match call.
Comment 3 Bobby Holley (:bholley) (busy with Stylo) 2012-05-31 09:37:14 PDT
Looks green. Pushed to try:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d3d7c919fb50
Comment 4 Ed Morley [:emorley] 2012-06-01 08:41:09 PDT
https://hg.mozilla.org/mozilla-central/rev/d3d7c919fb50

Note You need to log in before you can comment on or make changes to this bug.