Last Comment Bug 760088 - content/chrome/dom/plugins/test/test_clear_site_data.html ran additional tests after finish() was called
: content/chrome/dom/plugins/test/test_clear_site_data.html ran additional test...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
-- minor (vote)
: mozilla16
Assigned To: Mats Palmgren (:mats)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 06:45 PDT by Mats Palmgren (:mats)
Modified: 2012-06-12 03:04 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Move the SimpleTest.finish() after the final test is done. (1.58 KB, patch)
2012-05-31 06:48 PDT, Mats Palmgren (:mats)
jaas: review+
Details | Diff | Splinter Review

Description User image Mats Palmgren (:mats) 2012-05-31 06:45:27 PDT
Fallout from the diagnostic patch in bug 677964.
Comment 1 User image Mats Palmgren (:mats) 2012-05-31 06:48:53 PDT
Created attachment 628708 [details] [diff] [review]
Move the SimpleTest.finish() after the final test is done.
Comment 2 User image Phil Ringnalda (:philor) 2012-05-31 21:49:42 PDT
Comment on attachment 628708 [details] [diff] [review]
Move the SimpleTest.finish() after the final test is done.

I'm not sure who the right reviewer is, but since this is the first time I've ever seen PluginUtils, I'm pretty sure it's not me.
Comment 4 User image Josh Aas 2012-06-08 07:25:58 PDT
Which exact test (line #) was running after finish, and what were the conditions? I don't understand why this helps.
Comment 5 User image Mats Palmgren (:mats) 2012-06-08 08:03:02 PDT
It's the ok() test on line 22:
  ok(PluginUtils.withTestPlugin(runTest), "Test plugin found");

SimpleTest.finish() currently runs inside the 'runTest' callback
so the final ok() runs after it.
Comment 6 User image Mats Palmgren (:mats) 2012-06-08 08:04:30 PDT
correction: line 23.
Comment 8 User image Graeme McCutcheon [:graememcc] 2012-06-12 03:04:28 PDT
https://hg.mozilla.org/mozilla-central/rev/e551cdc8a8b1

Note You need to log in before you can comment on or make changes to this bug.