Last Comment Bug 760094 - Ignore .egg-info directories in source tree
: Ignore .egg-info directories in source tree
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
Depends on: 758823
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 07:02 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-06-01 08:41 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
gitignore update (483 bytes, patch)
2012-05-31 07:02 PDT, Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Review
gitignore and hgignore update (793 bytes, patch)
2012-05-31 07:47 PDT, Kartikaya Gupta (email:kats@mozilla.com)
ted: review+
justin.lebar+bug: feedback+
Details | Diff | Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-05-31 07:02:47 PDT
Created attachment 628709 [details] [diff] [review]
gitignore update

See bug 758823 for more discussion on where these are coming from and why they can't be gotten rid of easily.
Comment 1 Justin Lebar (not reading bugmail) 2012-05-31 07:17:30 PDT
Please update the .hgignore as well.
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-31 07:47:23 PDT
Created attachment 628737 [details] [diff] [review]
gitignore and hgignore update
Comment 3 Justin Lebar (not reading bugmail) 2012-05-31 07:53:47 PDT
Comment on attachment 628737 [details] [diff] [review]
gitignore and hgignore update

These patterns wfm, but I still want ted to r+ the idea of hg/git-ignoring these files.
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2012-05-31 08:13:31 PDT
Kats, is there any particular reason why you asked for me review on this?  I know next to nothing about these directories.  (OK, fine, I don't know anything at all about them!)
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-31 08:25:08 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #4)
> Kats, is there any particular reason why you asked for me review on this? 

No, just that you were the last person to touch .gitignore so I figured you would be ok reviewing such a change.
Comment 6 Ted Mielczarek [:ted.mielczarek] 2012-05-31 09:14:25 PDT
Comment on attachment 628737 [details] [diff] [review]
gitignore and hgignore update

Review of attachment 628737 [details] [diff] [review]:
-----------------------------------------------------------------

Since there's no way to stop producing them without breaking the way I want things to work, we might as well ignore them.
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-31 09:27:50 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/cef3bda40d40
Comment 8 Ed Morley [:emorley] 2012-06-01 08:41:18 PDT
https://hg.mozilla.org/mozilla-central/rev/cef3bda40d40

Note You need to log in before you can comment on or make changes to this bug.