Closed Bug 760119 Opened 7 years ago Closed 6 years ago

Switching back from custom install to standard doesn't reset the installation folder

Categories

(Firefox :: Installer, defect)

13 Branch
All
Windows 7
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: pauly, Unassigned)

Details

Steps to reproduce:
1. Choose custom install
2. Set the destination folder to: C:\Program Files (x86)\Mozilla Firefox aaa
3. Go back
4. Choose standard install

Actual results:
Firefox will be installed to the following location:
C:\Program Files (x86)\Mozilla Firefox aaa

Expected results:
Firefox will be installed to the following location:
C:\Program Files (x86)\Mozilla Firefox
I'm pretty sure the actual results is the correct results.  I think it should re-use the existing path you installed to.  CC'ing rstrong who can confirm and I think resolve.
The problem is I didn't install anything actually, I only changed the destination folder and press Back. Why would I go back from custom to a standard installation if not for resetting the destination folder ?
I'll defer to rstrong's knowledge of the code here but I would expect, from a UX perspective:

Custom > Change folder > Back > Standard, revert to the standard default configuration (effectively an "undo")

That's not to say the current behaviour is wrong; and if this were to be resolved INVALID/WONTFIX I would not argue. Though, I think it's reasonable to expect the average user to expect going back to Standard will revert to defaults.

Again, I'll defer to rstrong's opinion in this matter.
I think this bug report is perfectly valid though not a high priority at this time. We'll probably fix it once we have time to do the installer rewrite.
> The problem is I didn't install anything actually, I only changed 
> the destination folder and press Back.

Gotcha, sorry I didn't read the original steps close enough.
This is fixed in the stub installer which is our primary distribution method with the removal of the back button so wontfixing. For the full installer it will be fixed when I have time to rewrite it to use the same UI as the stub installer.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.