need to build redit.exe as part of a b2g windows desktop

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jhford, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Looks like we need to build redit.exe but aren't for Windows b2g desktop builds

e:/builds/moz2_slave/try-w32/build/obj-firefox/config/nsinstall.exe -D ../../dist/bin/chrome/icons/default
cp /e/builds/moz2_slave/try-w32/build/b2g/app/b2g.ico ../../dist/bin/chrome/icons/default/b2g.ico
e:/builds/moz2_slave/try-w32/build/obj-firefox/dist/bin/redit.exe ../../dist/bin/b2g.exe /e/builds/moz2_slave/try-w32/build/b2g/app/b2g.ico
make[6]: Leaving directory `/e/builds/moz2_slave/try-w32/build/obj-firefox/b2g/app'
make[5]: Leaving directory `/e/builds/moz2_slave/try-w32/build/obj-firefox/b2g'
make[4]: Leaving directory `/e/builds/moz2_slave/try-w32/build/obj-firefox'
make[3]: Leaving directory `/e/builds/moz2_slave/try-w32/build/obj-firefox'
make[2]: Leaving directory `/e/builds/moz2_slave/try-w32/build/obj-firefox'
make[1]: Leaving directory `/e/builds/moz2_slave/try-w32/build'
make[6]: e:/builds/moz2_slave/try-w32/build/obj-firefox/dist/bin/redit.exe: Command not found
make[6]: *** [libs] Error 127
make[5]: *** [libs] Error 2
make[4]: *** [libs_tier_app] Error 2
make[3]: *** [tier_app] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2
Depends on: 760141
Created attachment 630178 [details] [diff] [review]
build redit.exe for b2g on Windows

We should build redit.exe for Windows B2G builds
Attachment #630178 - Flags: review?(jones.chris.g)
Comment on attachment 630178 [details] [diff] [review]
build redit.exe for b2g on Windows

Please remove the tab character here.

rs=me with that.
Attachment #630178 - Flags: review?(jones.chris.g) → review+
Comment on attachment 630178 [details] [diff] [review]
build redit.exe for b2g on Windows

Checked in with the tab removed.

http://hg.mozilla.org/mozilla-central/rev/e5b003aaf179
I'm trying to build B2G on Windows (using a working env for browser build) and am hitting this bug.  My m-c is up to date.
Created attachment 637237 [details]
build log
Created attachment 637239 [details] [diff] [review]
fix v1

This fixes the build issue for me.
Attachment #637239 - Flags: review?(jones.chris.g)
Duplicate of this bug: 769662
Attachment #637239 - Flags: review?(jones.chris.g) → review+
Comment on attachment 637239 [details] [diff] [review]
fix v1

I landed this, minus the TEST_DIRS bits (because they don't exist in the file anymore at all): https://hg.mozilla.org/mozilla-central/rev/f6827c0d913e
Should be fixed now. We won't have anything actually hitting this code until the builds from bug 760168 are turned on, though. (Should be in the next 1-2 days.)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(In reply to Ben Hearsum [:bhearsum] from comment #8)
> Comment on attachment 637239 [details] [diff] [review]
> fix v1
> 
> I landed this, minus the TEST_DIRS bits (because they don't exist in the
> file anymore at all): https://hg.mozilla.org/mozilla-central/rev/f6827c0d913e

Thanks :)
You need to log in before you can comment on or make changes to this bug.