Console API silently swallows unknown function calls

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 628759 [details]
Testcase

Attached testcase should say PASS.  It says FAIL.

When fixing, we have to be careful about possibly-missing APIs (e.g. should we have a console.assert?)
Component: Developer Tools: Console → DOM
Product: Firefox → Core
QA Contact: developer.tools.console → general

Comment 1

6 years ago
I think this is because of bug 614350. We now have enough of the console API that it's probably okay to remove that behavior.

I've filed bug 760193 for console.assert.
Er.. is consoleapi under dom for some reason?
I meant in Bugzilla terms.
Yes, it's entirely DOM code...

Comment 6

3 years ago
I can reproduce it on Fx ESR 38, but not on Fx40+.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.