The default bug view has changed. See this FAQ.

The inspector node menu feature allows the user to remove tabbed browsing

RESOLVED FIXED in Firefox 14

Status

()

Firefox
Developer Tools: Inspector
P1
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ioana (away), Assigned: paul)

Tracking

({regression})

14 Branch
Firefox 16
regression
Points:
---

Firefox Tracking Flags

(firefox14+ verified, firefox15+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20120530 Firefox/14.0a2
BuildID: 20120530042008

STR:
1. Launch Firefox.
2. Load any website in the browser (e.g. https://www.google.ro/).
3. Right-click on any item on the page and select "Inspect Element" (or press 4. Ctrl+Shift+I/Cmd+Alt+I and select an item on the page).
5. Click on the "Node Operations" button (triangle facing down).
6. Click "Delete Node".
7. Repeat steps 5 and 6 until deleting the "html" node.
8. Click on the "Select element with mouse" button and select "tabbrowser#content". Delete this node too.

After step 7, "undefined" is displayed as a node. When the user tries to select another item, only "tabbrowser#content" is available. After the user deletes this element, the browser becomes mostly unusable: all its features that use tabbed browsing become unresponsive (the user can't open/close tabs, move to already open tabs etc).

I don't already have a regression range for this issue, but I will try to add one tomorrow.
(Reporter)

Comment 1

5 years ago
Last good nightly: 2012-04-13
First bad nightly: 2012-04-14

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=10622eaff4fc&tochange=364f0a5a1d2d

This issue also reproduces on the latest Nightly and Aurora builds (2012-06-01).
nice!
Seems to be a serious enough regression, did we want to track for Firefox 14?
tracking-firefox14: --- → ?
Keywords: regression

Comment 4

5 years ago
Observation :

After reproducing this issue, if a new window is opened, bookmark toolbar is missing.

Updated

5 years ago
Summary: The PseudoClass Lock feature allows the user to remove tabbed browsing → The inspector node menu feature allows the user to remove tabbed browsing

Comment 5

5 years ago
Tracking for 14 although this would not block release of 14.
tracking-firefox14: ? → +
(Assignee)

Updated

5 years ago
Priority: -- → P1
(Assignee)

Updated

5 years ago
Assignee: nobody → paul
(Assignee)

Updated

5 years ago
Duplicate of this bug: 746943
(Assignee)

Comment 7

5 years ago
Created attachment 631334 [details] [diff] [review]
v1
(Assignee)

Updated

5 years ago
Attachment #631334 - Flags: review?(rcampbell)
tracking 15 as well. we'll want it everywhere, if possible.
Status: NEW → ASSIGNED
tracking-firefox15: --- → ?
This patch looks reasonable. I wonder if we want a stricter comparison on doc != this.chromeDoc (!== ? ! === ?)? to allow highlighting chrome in content. Maybe not necessary.

I'm currently having an issue highlighting chrome://browser/content/browser.xul in my nightly. Investigating that.
Attachment #631334 - Flags: review?(rcampbell) → review+
tracking-firefox15: ? → +
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/42d4a34aced6
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/42d4a34aced6
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Whiteboard: [fixed-in-fx-team]
(Assignee)

Comment 12

5 years ago
Comment on attachment 631334 [details] [diff] [review]
v1

[Approval Request Comment]
User impact if declined: user can break firefox
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): small patch
String or UUID changes made by this patch: nope
Attachment #631334 - Flags: approval-mozilla-aurora?
Comment on attachment 631334 [details] [diff] [review]
v1

[Triage Comment]
Patch looks low enough risk for Aurora, given where we are in the cycle.
Attachment #631334 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-aurora]
https://hg.mozilla.org/releases/mozilla-aurora/rev/7d0d22b6d4b3
status-firefox15: --- → fixed
tracking-firefox15: + → ---
Whiteboard: [land-in-aurora]
(Assignee)

Comment 15

5 years ago
Comment on attachment 631334 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: user can break firefox
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): small amount of code
String or UUID changes made by this patch: no
Attachment #631334 - Flags: approval-mozilla-beta?
Comment on attachment 631334 [details] [diff] [review]
v1

Looks fine for this next beta, please update status flags once landed.
Attachment #631334 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 17

5 years ago
https://tbpl.mozilla.org/?tree=Mozilla-Beta&rev=61daf443bddb
status-firefox14: --- → fixed
tracking-firefox14: + → ---
Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0

This seems to be fixed on Firefox 14 beta 11 (even if I don't see any patch landed in the bug)- the Inspector does not allow the user to remove tabbed browsing, but shouldn't the "Delete node" option for the "html" node be grayed out to avoid user confusion? 
Should I file a new bug for this?
status-firefox14: fixed → verified
tracking-firefox14: --- → +
tracking-firefox15: --- → +
(Assignee)

Comment 19

5 years ago
> Should I file a new bug for this?

Yes please.
Filed Bug 772371. 
Thank you Paul.
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0

Verified on Firefox 15 beta 3 that removing tabbed browsing is not allowed. Verified using the STR from the Description on Windows 7, Ubuntu 12.04 and Mac OS X 10.6.
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.