If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add T-TeleSec GlobalRoot Class 3 root certificate to NSS

RESOLVED FIXED in 3.14

Status

NSS
CA Certificates Code
--
enhancement
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Kathleen Wilson, Assigned: kaie)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 628917 [details]
T-Systems Class 3 Root Cert

This bug requests inclusion in the NSS root certificate store of the following certificate, owned by T-Systems.

Friendly name: T-TeleSec GlobalRoot Class 3
Certificate location: http://www.telesec.de/downloads/GlobalRoot_Class_3.cer
SHA1 Fingerprint: 55:A6:72:3E:CB:F2:EC:CD:C3:23:74:70:19:9D:2A:BE:11:E3:81:D1
Trust flags: Websites
Test URL: https://root-class3.test.telesec.de 

This CA has been assessed in accordance with the Mozilla project guidelines, and the certificates approved for inclusion in bug #669849.

The next steps are as follows:

1) A representative of the CA must confirm that all the data in this bug is correct, and that the correct certificates have been attached.

2) A Mozilla representative creates a patch with the new certificates, and provides a special test version of Firefox.

3) A representative of the CA uses the test version of Firefox to confirm (by adding a comment in this bug) that the certificates have been correctly imported and that websites work correctly.

4) The Mozilla representative requests that another Mozilla representative review the patch.

5) The Mozilla representative adds (commits) the patch to NSS, then closes this bug as RESOLVED FIXED.

6) At some time after that, various Mozilla products will move to using a version of NSS which contains the certificates. This process is mostly under the control of the release drivers for those products.
(Reporter)

Updated

5 years ago
Severity: normal → enhancement
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 1

5 years ago
Carsten, Please see step #1 above.
(Reporter)

Updated

5 years ago
Blocks: 760313

Comment 2

5 years ago
Kathleen,
thanks for your support during the approval procedure.

I'm happy to confirm that the provided details are correct and the attached certificate is the correct one.
(Reporter)

Comment 3

5 years ago
Thanks for confirming that the data in this bug is correct.

Root inclusions and changes are usually grouped and done as a batch when there is
either a large enough set of changes or about every 3 months.

At some point in the next 3 months a test build will be provided and this bug
will be updated to request that you test it. Since you are cc'd on this bug,
you will get notification via email when that happens.

Comment 4

5 years ago
Hi Kathleen,

3 month are gone without any "sign". Would it be possible to get a short status update? Is there another bug I might get further information - or will all information related to this posted into this bug? 
I don't want to be a pain, but just to be sure :-)

Thanks
Carsten
(Assignee)

Updated

5 years ago
Assignee: nobody → kaie
(Assignee)

Updated

5 years ago
Blocks: 795355
(Assignee)

Comment 5

5 years ago
Sorry for the delay

The test build is available at
  http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kaie@kuix.de-564a5a2618f5/
or from
  http://kuix.de/mozilla/tryserver-roots-20121004/

Can a CA representative please verify the trust settings for correctness?

(see initial comments in this bug,
 and you should make sure that you're using a fresh profile
 to make sure you really see the trust bits provided by this build,
 not trust settings that you had set manually in an application profile.)

Comment 6

5 years ago
Hi Kai,

I have downloaded the Mac OS binary and tested this build against our test certificate at: https://root-class3.test.telesec.de/

I can confirm that this test certificate chaining to our new root "T-TeleSec GlobalRoot Class 3" is recognized correctly by this Firefox :-)
I will attach a screenshot to this bug.

One more question: 
This new root is intended to issue EV certificates. Therefore we have applied to enable it for EV, also. Is there anything else we have to do regarding this?

Thanks a lot,
Carsten

Comment 7

5 years ago
Created attachment 668428 [details]
Screenshot: Test Certificate in Firefox Build

Screenshot taken from the provided FF buid attached.
(Assignee)

Comment 8

5 years ago
Enabling for EV is done in a separate step in a seprate product.

This is about adding the root to the general purpose NSS library.

There will be a separate task to bless your root for EV in the Firefox product.

Comment 9

5 years ago
Thanks for your quick response!

When I send the comment I remembered that there is a dedicated bug to track EV enabling of the root :-S
(Assignee)

Comment 10

5 years ago
fixed in bug 795355
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.14
You need to log in before you can comment on or make changes to this bug.