saveURI api busted

VERIFIED FIXED in mozilla0.9

Status

()

Core
Embedding: APIs
--
major
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Marco Pesenti Gritti, Assigned: Adam Lock)

Tracking

Trunk
mozilla0.9
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Saving images with this api is no more working in mozilla cvs:

/mozilla/embedding/browser/webBrowser/nsIWebBrowserPersist.idl
void saveURI(in nsIURI aURI, in nsIInputStream aPostData, in string aFileName);

I think it can be caused by this change: (the date is near when I noticed the
bug, and it seems related)

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/embedding/browser/webBrowser&command=DIFF_FRAMESET&file=nsWebBrowserPersist.cpp&rev1=1.11&rev2=1.12&root=/cvsroot

I can reproduce on this url for example:

http://www.gnome.org/images/banner-gnomeis
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

17 years ago
Hi, do you have the Mozilla source? Can you try deleting the line 
"persist->Release();" from the method nsWebBrowser::SaveURI in 
mozilla/embedding/browser/webBrowser/nsWebBrowser.cpp and see if that fixes your 
problems?

I recently changed how the refcounting behaviour works and it's possible that 
the line is the cause of your problems. If so let me know and I will submit a 
patch.
Target Milestone: --- → mozilla0.9.1
(Reporter)

Comment 2

17 years ago
Hi,
Removing persist->Release () fix it.
It would be really good if this could be checked in before 0.9 :)
(Assignee)

Comment 3

17 years ago
Created attachment 31180 [details] [diff] [review]
One line patch
(Assignee)

Comment 4

17 years ago
The 0.9 freeze is tonight but I will try and sneak it in since I have another 
patch on that file to checkin as well. It's very low risk.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9
(Assignee)

Comment 5

17 years ago
Fix is checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Correction: Changing QA contact for the Embed API bugs to David Epstein.
QA Contact: mdunn → depstein

Comment 7

17 years ago
changed qa contact to dsirnapalli. He's working with nsIWebBrowserPersist.
QA Contact: depstein → dsirnapalli

Comment 8

17 years ago
checked nsWebBrowser.cpp. line "persist->Release();" no longer exists in  method 
SaveURI. marking it  to verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.