java.lang.IllegalArgumentException: Receiver not registered: org.mozilla.gecko.GeckoNetworkManager@<addr>: at android.app.LoadedApk.forgetReceiverDispatcher(LoadedApk.java)

VERIFIED FIXED in Firefox 18

Status

()

Firefox for Android
General
--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, topcrash})

Trunk
Firefox 18
ARM
Android
crash, topcrash
Points:
---

Firefox Tracking Flags

(firefox16 affected, firefox17 affected, firefox18 fixed)

Details

(Whiteboard: [native-crash], crash signature)

(Reporter)

Description

6 years ago
There are seven crashes over the last four weeks across all versions.
It might be related to bug 744850.

java.lang.IllegalArgumentException: Receiver not registered: org.mozilla.gecko.GeckoNetworkManager@41415940
	at android.app.LoadedApk.forgetReceiverDispatcher(LoadedApk.java:628)
	at android.app.ContextImpl.unregisterReceiver(ContextImpl.java:1066)
	at android.content.ContextWrapper.unregisterReceiver(ContextWrapper.java:354)
	at org.mozilla.gecko.GeckoNetworkManager.stopListening(GeckoNetworkManager.java:146)
	at org.mozilla.gecko.GeckoNetworkManager.stop(GeckoNetworkManager.java:141)
	at org.mozilla.gecko.GeckoApp.onApplicationPause(GeckoApp.java:2177)
	at org.mozilla.gecko.GeckoApplication.onActivityPause(GeckoApplication.java:46)
	at org.mozilla.gecko.GeckoActivity.onPause(GeckoActivity.java:24)
	at android.app.Activity.performPause(Activity.java:4563)
	at android.app.Instrumentation.callActivityOnPause(Instrumentation.java:1195)
	at android.app.ActivityThread.performPauseActivity(ActivityThread.java:2693)
	at android.app.ActivityThread.performPauseActivity(ActivityThread.java:2662)
	at android.app.ActivityThread.handlePauseActivity(ActivityThread.java:2640)
	at android.app.ActivityThread.access$800(ActivityThread.java:123)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1154)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.IllegalArgumentException%3A+Receiver+not+registered%3A+org.mozilla.gecko.GeckoNetworkManager%40%3Caddr%3E%3A+at+android.app.LoadedApk.forgetReceiverDispatcher%28LoadedApk.java%29
I was able to reproduce once this crash on the latest RC build performing these STR:

1. Go to news.google.com
2. Long tap on a link and bookmark it
3. Go to Awesomescreen > Bookmarks and long tap on the added bookmark and add a shortcut to the Home Screen
4. Tap on Home button and tap on the added shortcut
5. Go back to Awesomescreen > Bookmarks and remove the added bookmark at step 2
6. Repeat step 4

Expected result:
No crash occurs after step 6.

Actual result:
This crash occurs after step 6:
https://crash-stats.mozilla.com/report/index/bp-7f081cf5-bcc5-49f9-ade3-60ff62120807

--
Firefox 14.0.2 build 2 (2012-08-06)
Device: Galaxy Nexus
OS: Android 4.1.1
Lucas, does this crash look like fallout from your fix for bug 744850? Curiously, I see Socorro crash reports for Firefox 14, Beta 15, and Aurora 16 but not Nightly 17.
status-firefox14: --- → affected
status-firefox15: --- → affected
status-firefox16: --- → affected
This crash occurred on the latest Nightly after I quit Fennec while I was in Reader Mode:
https://crash-stats.mozilla.com/report/index/bp-551674ab-7fde-4cb5-8bbd-fa01f2120813

--
Firefox 17.a1 (2012-08-13)
Device: Galaxy Nexus
OS: Android 4.1.1
status-firefox17: --- → affected
(Reporter)

Comment 4

6 years ago
It's #8 top crasher in 14.0.1, #24 in 15.0b4, #18 in 16.0a2, and #32 in 17.0a1.
Keywords: topcrash
(In reply to Cristian Nicolae (:xti) from comment #1)
> I was able to reproduce once this crash on the latest RC build performing
> these STR:
> 
> 1. Go to news.google.com
> 2. Long tap on a link and bookmark it
> 3. Go to Awesomescreen > Bookmarks and long tap on the added bookmark and
> add a shortcut to the Home Screen
> 4. Tap on Home button and tap on the added shortcut
> 5. Go back to Awesomescreen > Bookmarks and remove the added bookmark at
> step 2
> 6. Repeat step 4
> 
> Expected result:
> No crash occurs after step 6.
> 
> Actual result:
> This crash occurs after step 6:
> https://crash-stats.mozilla.com/report/index/bp-7f081cf5-bcc5-49f9-ade3-
> 60ff62120807
> 
> --
> Firefox 14.0.2 build 2 (2012-08-06)
> Device: Galaxy Nexus
> OS: Android 4.1.1

This doesn't crash for me.
As long as we keep using GeckoApp.mAppContext, we are not going to be able to fix these issues.
1. It should be private member.
2. When mAppContext changes, we should try to unregister for the old value -- just in case we have one.

And making it a private member is a really big task.
(In reply to Sriram Ramasubramanian [:sriram] from comment #5)

> This doesn't crash for me.

I cannot reproduce this either on the latest Nightly using the STR from comment #1. 

--
Firefox 18.0a1 (2012-08-30)
Device: Galaxy Note
OS: Android 4.0.4
(Reporter)

Comment 8

6 years ago
It's #22 top crasher in 15.0, #18 in 16.0b1, and #30 in 17.0a2.
status-firefox14: affected → ---
status-firefox15: affected → ---
status-firefox16: affected → ---
status-firefox17: affected → ---
Keywords: topcrash
(Reporter)

Updated

6 years ago
Depends on: 761706
(Reporter)

Comment 9

6 years ago
It's #9 top crasher in 16.0.1 and #23 in 17.0b1.
Keywords: topcrash
status-firefox16: --- → affected
status-firefox17: --- → affected
status-firefox18: --- → affected
Scoobi?  Just wondering.. why did you remove the affected flags?  Was that just an accident?
(Reporter)

Comment 11

6 years ago
(In reply to Naoki Hirata :nhirata from comment #10)
> Scoobi?  Just wondering.. why did you remove the affected flags?  Was that
> just an accident?
Maintaining those flags is a hard work that doesn't add any useful information (in this case, Trunk means any version as the regression keyword is missing) and I think we should only focus on the tracking flags (generic and fennec).
Has this happened at all on a build that has bug 761706? That should have fixed this issue. The "more reports" link in comment #0 seems to indicate that it is fixed on 18 and 19, but I might have missed something.
(Reporter)

Comment 13

6 years ago
(In reply to Kartikaya Gupta (:kats) from comment #12)
> Has this happened at all on a build that has bug 761706?
The Nightly population is rarely affected but the Aurora population is. There are crashes in 17.0a2 at least one build out of three, but no crashes in 18.0a2 so it's fixed in Branch 18.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox18: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18

Comment 14

6 years ago
(In reply to Scoobidiver from comment #11)
> Maintaining those flags is a hard work that doesn't add any useful
> information (in this case, Trunk means any version as the regression keyword
> is missing) and I think we should only focus on the tracking flags (generic
> and fennec).

Actally, for us internally, those flags are actually useful, for example to know on which branches something needs to land or will not be landed. Tracking is orthogonal to that.

Comment 15

6 years ago
Using the steps from Comment 1: 
> 1. Go to news.google.com
> 2. Long tap on a link and bookmark it
> 3. Go to Awesomescreen > Bookmarks and long tap on the added bookmark and
> add a shortcut to the Home Screen
> 4. Tap on Home button and tap on the added shortcut
> 5. Go back to Awesomescreen > Bookmarks and remove the added bookmark at
> step 2
> 6. Repeat step 4

or 

> This crash occurred on the latest Nightly after I quit Fennec while I was in
> Reader Mode:

I can not reproduce this on Fx 20 (Nightly) nor on Fx 18 (Beta). Marking bug as Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.