Last Comment Bug 760424 - browser_tab_dragdrop.js is buggy, doesn't remove the correct event listener
: browser_tab_dragdrop.js is buggy, doesn't remove the correct event listener
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug] (high review load, please consider other reviewers)
:
Mentors:
Depends on:
Blocks: 734015
  Show dependency treegraph
 
Reported: 2012-06-01 06:34 PDT by Olli Pettay [:smaug] (high review load, please consider other reviewers)
Modified: 2012-06-01 10:23 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.46 KB, patch)
2012-06-01 06:52 PDT, Olli Pettay [:smaug] (high review load, please consider other reviewers)
mats: review+
Details | Diff | Review

Description Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-06-01 06:34:04 PDT
browser_tab_dragdrop.js tries to remove not-existing event listener, and
ends up handling load event from iframes although it doesn't expect it.

Patch coming.
Comment 1 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-06-01 06:52:57 PDT
Created attachment 629172 [details] [diff] [review]
patch

Mats, I think you wrote the test long ago for bug 449734.
Comment 2 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-06-01 07:02:33 PDT
Comment on attachment 629172 [details] [diff] [review]
patch

And the var c = 0; is a leftover from debugging. I'll remove it.
Comment 3 Mats Palmgren (:mats) 2012-06-01 07:30:33 PDT
Comment on attachment 629172 [details] [diff] [review]
patch

Thanks.
Comment 4 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-06-01 09:30:13 PDT
https://hg.mozilla.org/mozilla-central/rev/def37b64a758
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-01 10:23:39 PDT
Looks like browser_tab_dragdrop2.js has a similar issue:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/test/browser_tab_dragdrop2.js?rev=574b0fb35604#21
(added on window_B.gBrowser, removed on window_B)
which might explain bug 598294?

Note You need to log in before you can comment on or make changes to this bug.