procedure entry point could not be located in xpcom.dll

RESOLVED DUPLICATE of bug 71010

Status

()

RESOLVED DUPLICATE of bug 71010
18 years ago
7 years ago

People

(Reporter: eol1, Assigned: dprice)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Build: 2001041320

Exact error message:  The procedure entry point ??
0nsInputFileStream@@QAE@ABV@@Z could not be located in the dynamic link library 
xpcom.dll.

Get the bug in 2 places (same action though)...one if you click the submit 
button or two if you type in the information and just hit enter on the 
keyboard, same issue though.

Comment 1

18 years ago
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001041704

Try downloading the latest nightlies and creating a new profile and see if that
fixes it.
(Reporter)

Comment 2

18 years ago
Build: 2001041704
Platform: Windows2000

Exact same error EXCEPT this time after i click ok on the error box, it 
continues with the action...last time it stopped at the error box with no 
continuation (?sp).

Comment 3

18 years ago
Created attachment 31466 [details]
Message box with error showing

Comment 4

18 years ago
Build 2001041804
Windows 2000

Have seen this in builds over the last couple of days. Did a search on 'mozilla'
at www.google.com to generate the message. After clicking OK, the search goes
ahead without incident. Similar behavior on other forms with 'submit' buttons.
The xpcom.dll is dated April 18.

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 71010 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Seeing this on all form submissions. Confirming and nominating for mozilla 0.9.
Can't do a milestone build with warning dialogs like this. cc'ing scc since this
looks like string stuff.
Status: RESOLVED → NEW
Ever confirmed: true
Keywords: mozilla0.9

Comment 7

18 years ago
Edward, this may be the same root problem, but bug 71010 cites a different
missing entry point than this bug.

Comment 8

18 years ago
This bug has a status of NEW, *and* a resolution of DUPLICATE.  Should this
even be possible?

Comment 9

18 years ago
attempting to "Clear the resolution"
Resolution: DUPLICATE → ---

Comment 10

18 years ago
Looks like this symbol is only defined in the win32 order file.  I talked with
dprice about this, and he says that symbols only defined in there should not
cause any warnings other than build warnings.  I am assigning to him, since it
seems to be something on which he is working.  If it turns out not to be the
case, it will come back to me.

He asked that you try rebuilding with this symbol removed from win32.order and
see if the problem still exists.  Please add your results to this bug.  Thanks.
Assignee: kandrot → dprice
(Assignee)

Comment 11

18 years ago
there are a couple of bugs like this floating around.  Are people seeing this
with debug builds?  win32.order is only used when linking optimized builds.  The
linker is only supposed to throw warnings when it comes accross enties in an
order file that aren't in the source.  I remain confused and continue to work
toward enlightenment.

Comment 12

18 years ago
Still seeing this (same error shown in Steve Zweep's screenshot) on every form
submit using 2001-04-24-04 commercial release build on WinNT.

Comment 13

18 years ago
The other similar bug to this is bug 71010.   Is there any way to get this into
0.9 (if a fix is close, of course)?

Comment 14

18 years ago
I'm seeing this also when I use the preloader. Then, this box appears everytime
the preloader is started and loads the modules.

Another case is the automated start of Mozilla after the installation of a
nightly using "mozilla-win32-installer.exe".

I'm running Win2k.

Comment 15

18 years ago
*** Bug 76136 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
*** Bug 77874 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
*** Bug 77827 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 18

18 years ago
I have a new set of order files generated from today's branch.  Should remove
all of the problems people are seeing.  Seeking approval from
drivers@mozilla.org to check it in.

Comment 19

18 years ago
This has already been checked into the branch, right?

Comment 20

18 years ago
Created attachment 32715 [details]
Mozilla Error in Windows 2000 Build 2001043004

Comment 21

18 years ago
I have attached the error I still get in Build 2001043004. This mainfests itself
when I enter data into forms and hit ok/submit/whatever. Not all forms but most
e.g. www.google.com

Comment 22

18 years ago
Due to other problems I removed Mozilla and reinstalled it again and the problem
has gone.

Comment 23

18 years ago
Same resolution here: Confirmed this was still happening in 2001043004 (Windows
installer) build; Did a complete uninstall; Reinstalled same build to a fresh
directory ==> problem disappeared.

Comment 24

18 years ago
Same here.  However, using the Uninstall Mozilla icon found in the Mozilla-made
folder (at install) wanted to remove something in the .8 range so I used
Uninstall from Add/Remove Programs, and that worked.

Comment 25

18 years ago
An internal user received this error.  I'm just adding the info as it may help.  
The user is using Windows 2000.

Now I want to know if downloading a binary from another server also gives you 
problems.  So how about our own netscape.com?  Try
http://home.netscape.com/download/0402101/10004-en-win32-6.01-base-128_qual.html
.

Can this copy install? 

[Srilakshmi Mudigere] I got the following error when I clicked on the Download 
Now button 

nsetscp6.exe - Entry Point Not Fount 

"The Procedure entry point?close@nsInputStream@@QAEXXZ could not be located in 
the dynamic link library xpcom.dll"

FYI: In fact, I got this same error when I was trying to submit a problem report 
using the netscape 6.5 browser.

When I click OK to the above message, I get the Downloading window which says 
this...

"This file has mime type application/octet-stream and cannot be viewed using 
Netscape 6. You can open it with another application, or save it to disk"

I recollet now that this was the same message I got trying to download the new 
Netscape 6.5 from sweetlou
(Assignee)

Comment 26

18 years ago

*** This bug has been marked as a duplicate of 71010 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.