Retry on connection failures, to address transient network errors

RESOLVED FIXED in Firefox 14

Status

Android Background Services
Android Sync
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: liuche, Assigned: liuche)

Tracking

unspecified
mozilla16
ARM
Android
Dependency tree / graph

Firefox Tracking Flags

(firefox14 fixed, firefox15 fixed, blocking-fennec1.0 +)

Details

(Whiteboard: [sync], [qa+])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This should also fix Bug 760360, which involves syncing on an unreliable network.

If the connection is closed while we process downloaded records, the sync fails. We should be more optimistic, because on unreliable networks, a simple retry of the connection should allow us to complete the sync.
tracking-fennec: --- → ?
Whiteboard: [sync, fix for 760360]
Blocks: 760360
tracking-fennec: ? → -
blocking-fennec1.0: --- → ?
mobile triage: blocks, duping tony's bug to here
tracking-fennec: - → ---
blocking-fennec1.0: ? → +
Duplicate of this bug: 760360
Whiteboard: [sync, fix for 760360] → [sync][work in progress]
Priority: -- → P1
Status: NEW → ASSIGNED
OS: Mac OS X → Android
Hardware: x86 → ARM
Blocks: 736393
No longer blocks: 760360
Whiteboard: [sync][work in progress] → [sync][needs review: nalexander]
Whiteboard: [sync][needs review: nalexander] → [sync]
Created attachment 630021 [details] [diff] [review]
Patch against m-i
https://hg.mozilla.org/integration/mozilla-inbound/rev/f0f924ac58d2

Updated

5 years ago
Target Milestone: --- → mozilla16
https://hg.mozilla.org/mozilla-central/rev/f0f924ac58d2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment #630021 - Attachment is patch: true
Comment on attachment 630021 [details] [diff] [review]
Patch against m-i

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: transient network errors cause missed syncs
Testing completed (on m-c, etc.): builds m-c and aurora
Risk to taking this patch (and alternatives if risky): low, patch is straightforward.
String or UUID changes made by this patch: none
Attachment #630021 - Flags: approval-mozilla-beta?
Attachment #630021 - Flags: approval-mozilla-aurora?
Attachment #630021 - Flags: approval-mozilla-beta?
Attachment #630021 - Flags: approval-mozilla-beta+
Attachment #630021 - Flags: approval-mozilla-aurora?
Attachment #630021 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-beta/rev/c4077ce9b0d6
status-firefox14: --- → fixed
https://hg.mozilla.org/releases/mozilla-aurora/rev/002be3d4ce41
status-firefox15: --- → fixed

Comment 9

5 years ago
Chenxia, how can this be verified?   at the very least, i'll retry my STR in bug 760360 from my home network next build.
Whiteboard: [sync] → [sync], [qa+]
(In reply to Tony Chung [:tchung] from comment #9)
> Chenxia, how can this be verified?   at the very least, i'll retry my STR in
> bug 760360 from my home network next build.

In the general case, you'll need an environment that induces transient network errors.

In this specific case, you're looking for an environment like your home network -- one that seems to drop idle connections quite rapidly.
Blocks: 762974
Still on the radar for verification on mozilla-15
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services
You need to log in before you can comment on or make changes to this bug.