All users were logged out of Bugzilla on October 13th, 2018

insertion point is one pixel to the left of where it should be when at end of text field

VERIFIED DUPLICATE of bug 48602

Status

()

VERIFIED DUPLICATE of bug 48602
18 years ago
18 years ago

People

(Reporter: jruderman, Assigned: sfraser_bugs)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Type "TTT" into any text field (location bar, html form textbox, html form 
textarea, composer).
2. Put the insertion point at the end of the text.

Result: in each case, the insertion point is one pixel to the right of where 
you'd expect it to be based on its location when it's between two of the 'T's.  
In the location bar, this causes the insertion point to touch the last T.  In 
an html form textbox, it causes the insertion point to overlap with the end of 
the last T.

This is very annoying when typing lower-case L or D into the location bar, 
since the insertion point ends up inverting most or all of the letter right 
after it's typed.

Comment 1

18 years ago
-> Simon
Assignee: trudelle → sfraser

Comment 2

18 years ago
There is a dependence on the font for this. At the end of a line, the position is
correct for the default serif font, and off to the left by one for sans-serif
and monospace for my win2k system. On Mac,  serif and sans-serif are off, but
monospace is ok (I think; didn't have a magnifier handy on Mac).

But then when it is in the middle of a line, on win2k, serif is off by one to
the right, while monospace and sans-serif exactly split the characters. (and mac, is
monospace off by one, and serif and sans-serif OK).
QA Contact: jrgm → sujay
(Assignee)

Comment 3

18 years ago


*** This bug has been marked as a duplicate of 48602 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
Verif dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.