Last Comment Bug 760774 - switch ARIA role map to atoms
: switch ARIA role map to atoms
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: alexander :surkov
:
Mentors:
Depends on:
Blocks: cleana11y
  Show dependency treegraph
 
Reported: 2012-06-02 01:31 PDT by alexander :surkov
Modified: 2012-06-08 04:21 PDT (History)
2 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (30.19 KB, patch)
2012-06-02 01:31 PDT, alexander :surkov
tbsaunde+mozbugs: review+
neil: superreview+
Details | Diff | Splinter Review

Description alexander :surkov 2012-06-02 01:31:10 PDT
Created attachment 629454 [details] [diff] [review]
patch
Comment 1 Trevor Saunders (:tbsaunde) 2012-06-06 21:42:57 PDT
Comment on attachment 629454 [details] [diff] [review]
patch

I'm not sure if the change to atoms will have a good or bad effect on perf for GetOrCreateAccessible() since on one hand no more convertion from utf16 to ascii, on the other we probably hurt locality some.  However I think if we find it matters we should replace binary search on special logic that knows the possible options.
Comment 2 alexander :surkov 2012-06-06 22:53:00 PDT
Neil, could you check strings code please?
Comment 3 neil@parkwaycc.co.uk 2012-06-07 05:39:46 PDT
Comment on attachment 629454 [details] [diff] [review]
patch

>+  const nsDependentString ARIARoleString() const
>+    { return nsDependentAtomString(*roleAtom); }
Need to make the type of this function nsDependentAtomString too so that the compiler can perform RVO on it.
Comment 4 alexander :surkov 2012-06-07 09:24:58 PDT
landed with Neil's comment fixed https://hg.mozilla.org/integration/mozilla-inbound/rev/f86a9695194c
Comment 5 Graeme McCutcheon [:graememcc] 2012-06-08 04:21:24 PDT
https://hg.mozilla.org/mozilla-central/rev/f86a9695194c

(Merged by Ed Morley)

Note You need to log in before you can comment on or make changes to this bug.