The default bug view has changed. See this FAQ.

build failure in nsGenericHTMLElement.cpp when MOZ_MEDIA is undefined

RESOLVED FIXED in mozilla16

Status

()

Core
Audio/Video
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: aceman, Assigned: rillian)

Tracking

Trunk
mozilla16
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
/var/SSD/TB-hg/mozilla/content/html/content/src/nsGenericHTMLElement.cpp: In function 'bool IsVoidTag(mozilla::dom::Element*)':
/var/SSD/TB-hg/mozilla/content/html/content/src/nsGenericHTMLElement.cpp:1113:23: error: 'source' is not a member of 'nsGkAtoms'
gmake[8]: *** [nsGenericHTMLElement.o] Error 1
(Reporter)

Comment 1

5 years ago
Created attachment 629464 [details] [diff] [review]
patch
Attachment #629464 - Flags: review?(bzbarsky)
Would it be better to remove the #ifdef MOZ_MEDIA switches from the declaration in content/base/src/nsGkAtomList.h? The media-specific atoms are the only ones so conditionalized. And <track> is missing such a switch.

Is space in the atom list so precious that it's worth maintaining this configuration difference?
(Reporter)

Comment 3

5 years ago
If you propose only remove the switches from the nsGkAtomList.h declaration but not the rest of the code (so that the atoms are defined but never used), that would solve the occasional build breakage when somebody forgets those atoms are conditional on MOZ_MEDIA.
Created attachment 629474 [details] [diff] [review]
alternate patch

Yes, I meant just removing the #ifdef MOZ_MEDIA from the list of defined atoms.
Attachment #629474 - Flags: feedback?(acelists)
(Reporter)

Comment 5

5 years ago
Comment on attachment 629474 [details] [diff] [review]
alternate patch

I can confirm this fixes the build too.

I do not use --disable-ogg (and others) to save run-time memory, but to not compile useless stuff (with build dependencies) and save compile time and ld memory. Because I build Thunderbird.
Attachment #629474 - Flags: feedback?(acelists) → feedback+
Comment on attachment 629474 [details] [diff] [review]
alternate patch

Ok, thanks. bz, what's your preference?
Attachment #629474 - Flags: review?(bzbarsky)
Comment on attachment 629474 [details] [diff] [review]
alternate patch

r=me, but note that the new DOM bindings for WebGLContext almost certainly don't compile without MOZ_MEDIA either: I was told that was not a supported configuration, and there is no real infrastructure in WebIDL to make methods conditional on compiler ifdefs at the moment...
Attachment #629474 - Flags: review?(bzbarsky) → review+
Attachment #629464 - Flags: review?(bzbarsky) → review-
Thanks. Ready to land.
Keywords: checkin-needed
(Reporter)

Comment 9

5 years ago
For some reason it does work for me. Maybe TB does not compile webgl.
Assignee: acelists → giles
(Reporter)

Comment 10

5 years ago
bz was right, after today's hg update WebGLRenderingContextBinding.cpp fails.
So, is there a --disable-webgl mozconfig option?
There isn't, sorry.

Note that once we convert 2d canvas to new bindings it would have the same problem: the canvas spec explicitly lists HTMLVideoElement as one of the overloads for drawImage.  And I really doubt there will be a --disable-2d-canvas option...
(Reporter)

Comment 12

5 years ago
Fortunately removing --disable-ogg does work for me (it enables MOZ_MEDIA).
That is a pity the options are not there. I now must compile useless code (for TB). I'll try to file a bug for the options :)
https://hg.mozilla.org/integration/mozilla-inbound/rev/c9ec02b2b2e2
Keywords: checkin-needed
Target Milestone: --- → mozilla15
(This didn't make it in time for 15).
Target Milestone: mozilla15 → mozilla16
https://hg.mozilla.org/mozilla-central/rev/c9ec02b2b2e2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.