Closed Bug 760819 Opened 8 years ago Closed 7 years ago

Add an "alias" command to GCLI

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 731606
Future

People

(Reporter: msucan, Unassigned)

References

Details

(Whiteboard: [gclicommands])

Attachments

(1 file)

It would be useful to have a command as follows:

  alias add <new-alias-name> <command> [arguments]
  alias delete <alias-name>

If people use commands with complicated arguments they can just alias them.

(this is different from bug 731606)
Thanks for the suggestion.
Priority: -- → P3
Target Milestone: --- → Future
Filter on teabags
Whiteboard: [gclicommands]
I have been asked when we are implementing this more often than any other command. We don't need to worry about autocomplete here, we simply need to make it possible to add e.g. s as an alias for dbg step in.

I will implement:
alias create <alias> <command>
alias delete <alias>
Assignee: nobody → mratcliffe
I will use Mihai's suggestions
Attached patch Patch WIPSplinter Review
So, we have the following:
- alias add <name> <value>
- alias delete <name>
- alias list

The "only" thing we have left to do here is to allow the aliases to execute as a command. Joe wants us to hack on this together somewhere when he has time.
New component triage. Filter on "Lobster Thermidor aux crevettes with a Mornay sauce"
Component: Developer Tools → Developer Tools: Graphic Commandline and Toolbar
Assignee: mratcliffe → nobody
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731606
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.