Last Comment Bug 760837 - Intermittent browser_webconsole_bug_595934_message_categories.js | expectUncaughtException was called but no uncaught exception was detected!
: Intermittent browser_webconsole_bug_595934_message_categories.js | expectUnca...
Status: RESOLVED FIXED
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Mihai Sucan [:msucan]
:
: Brian Grinstead [:bgrins]
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-06-02 10:50 PDT by Mihai Sucan [:msucan]
Modified: 2012-11-25 19:31 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
proposed fix (1.70 KB, patch)
2012-06-02 11:06 PDT, Mihai Sucan [:msucan]
no flags Details | Diff | Splinter Review
[in-fx-team] disable subtest (1.39 KB, patch)
2012-06-02 11:22 PDT, Mihai Sucan [:msucan]
past: review+
Details | Diff | Splinter Review
test fix - rebased (1.78 KB, patch)
2012-06-03 02:14 PDT, Mihai Sucan [:msucan]
past: review+
Details | Diff | Splinter Review
[in-fx-team] test fix - improvements (6.06 KB, patch)
2012-06-13 11:50 PDT, Mihai Sucan [:msucan]
past: review+
Details | Diff | Splinter Review

Description User image Mihai Sucan [:msucan] 2012-06-02 10:50:20 PDT
Rev4 MacOSX Lion 10.7 fx-team opt test mochitest-other

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | expectUncaughtException was called but no uncaught exception was detected!

Push:
https://hg.mozilla.org/integration/fx-team/rev/05eeabb5db0a

Brief log:
https://tbpl.mozilla.org/php/getParsedLog.php?id=12311303&tree=Fx-Team
Comment 1 User image Mihai Sucan [:msucan] 2012-06-02 11:06:34 PDT
Created attachment 629501 [details] [diff] [review]
proposed fix
Comment 2 User image Mihai Sucan [:msucan] 2012-06-02 11:22:05 PDT
Created attachment 629502 [details] [diff] [review]
[in-fx-team] disable subtest
Comment 3 User image Treeherder Robot 2012-06-02 12:23:15 PDT
dcamp
https://tbpl.mozilla.org/php/getParsedLog.php?id=12312549&tree=Fx-Team
Rev4 MacOSX Lion 10.7 fx-team opt test mochitest-other on 2012-06-02 11:45:45
slave: talos-r4-lion-011

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | expectUncaughtException was called but no uncaught exception was detected!
Comment 4 User image Treeherder Robot 2012-06-02 12:23:29 PDT
past
https://tbpl.mozilla.org/php/getParsedLog.php?id=12312549&tree=Fx-Team
Rev4 MacOSX Lion 10.7 fx-team opt test mochitest-other on 2012-06-02 11:45:45
slave: talos-r4-lion-011

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | expectUncaughtException was called but no uncaught exception was detected!
Comment 5 User image Treeherder Robot 2012-06-02 12:23:40 PDT
msucan
https://tbpl.mozilla.org/php/getParsedLog.php?id=12312549&tree=Fx-Team
Rev4 MacOSX Lion 10.7 fx-team opt test mochitest-other on 2012-06-02 11:45:45
slave: talos-r4-lion-011

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | expectUncaughtException was called but no uncaught exception was detected!
Comment 6 User image Treeherder Robot 2012-06-02 12:37:00 PDT
past
https://tbpl.mozilla.org/php/getParsedLog.php?id=12312902&tree=Try
Rev4 MacOSX Lion 10.7 try opt test mochitest-other on 2012-06-02 11:54:39
slave: talos-r4-lion-034

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | expectUncaughtException was called but no uncaught exception was detected!
Comment 7 User image Treeherder Robot 2012-06-02 12:40:04 PDT
msucan
https://tbpl.mozilla.org/php/getParsedLog.php?id=12312911&tree=Fx-Team
Rev3 WINNT 6.1 fx-team opt test mochitest-other on 2012-06-02 11:49:49
slave: talos-r3-w7-017

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | expectUncaughtException was called but no uncaught exception was detected!
Comment 8 User image Mihai Sucan [:msucan] 2012-06-02 13:24:25 PDT
Comment on attachment 629502 [details] [diff] [review]
[in-fx-team] disable subtest

https://hg.mozilla.org/integration/fx-team/rev/ff4163e5f869
Comment 9 User image Dave Camp (:dcamp) 2012-06-02 17:03:12 PDT
https://hg.mozilla.org/mozilla-central/rev/ff4163e5f869

I'm leaving this open because Mihai mentioned that he wanted to fix the test for real.  Close if you decide otherwise please Mihai.
Comment 10 User image Treeherder Robot 2012-06-03 00:18:37 PDT
past
https://tbpl.mozilla.org/php/getParsedLog.php?id=12321882&tree=Try
Rev3 WINNT 6.1 try opt test mochitest-other on 2012-06-02 17:57:18
slave: talos-r3-w7-071

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | expectUncaughtException was called but no uncaught exception was detected!
Comment 11 User image Mihai Sucan [:msucan] 2012-06-03 02:14:42 PDT
Created attachment 629573 [details] [diff] [review]
test fix - rebased

This is the test fix that I'd like us to land after the aurora merge.

Green runs:
https://tbpl.mozilla.org/?tree=Try&rev=9603af047508
Comment 12 User image Panos Astithas [:past] 2012-06-03 02:19:41 PDT
Comment on attachment 629573 [details] [diff] [review]
test fix - rebased

Review of attachment 629573 [details] [diff] [review]:
-----------------------------------------------------------------

Yep, the plan seems solid. I suppose you could move it even further up if we ever get another similar failure.
Comment 13 User image Mihai Sucan [:msucan] 2012-06-13 11:50:41 PDT
Created attachment 632795 [details] [diff] [review]
[in-fx-team] test fix - improvements

The previous patch had no failures after many runs on the try server, but ultimately I was able to reproduce failures on my machine.

I had to make more changes, this is the patch I ended up with. No more failures on my machine.

Try push looks green again:
https://tbpl.mozilla.org/?tree=Try&rev=665e11e32550
Comment 14 User image Panos Astithas [:past] 2012-06-14 01:26:54 PDT
Comment on attachment 632795 [details] [diff] [review]
[in-fx-team] test fix - improvements

Review of attachment 632795 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js
@@ +159,5 @@
> +      },
> +      successFn: testNext,
> +      failureFn: function() {
> +        info("foundCategory " + foundCategory + " foundText " + foundText +
> +             "pageLoaded " + pageLoaded + " pageError " + pageError);

You probably want a space before pageLoaded inside the string literal.
Comment 15 User image Mihai Sucan [:msucan] 2012-06-14 05:00:34 PDT
Comment on attachment 632795 [details] [diff] [review]
[in-fx-team] test fix - improvements

https://hg.mozilla.org/integration/fx-team/rev/dc4abc6cf76d

Thank you Panos. I fixed that in the patch I landed.
Comment 16 User image Tim Taubert [:ttaubert] 2012-06-16 03:45:18 PDT
https://hg.mozilla.org/mozilla-central/rev/dc4abc6cf76d
Comment 17 User image Daniel Holbert [:dholbert] (away, returning Jan 17) 2012-11-20 17:06:54 PST
While looking into the failure from bug 802390 comment 18, I noticed that the commented subtest-numbering was off in this test, dating back to the cset in comment 15 / comment 16.  That test modified the numbering in such a way as to skip 13, so when the harness reports issues in tests #13 #14 and #15, those correspond to the chunks labeled as #14 #15 and #16 in the test file.

Anyway, I just fixed the numbering in the test:
  https://hg.mozilla.org/integration/mozilla-inbound/rev/2cfe4e2ada97
Comment 18 User image Mihai Sucan [:msucan] 2012-11-21 01:00:39 PST
Thank you Daniel. Yes, numbering was off for quite some time...
Comment 19 User image Ed Morley [:emorley] 2012-11-21 07:39:42 PST
https://hg.mozilla.org/mozilla-central/rev/2cfe4e2ada97

Note You need to log in before you can comment on or make changes to this bug.