Last Comment Bug 760882 - XBL Bindings appear in the debugger script dropdown if the debugger is open when the page is refreshed
: XBL Bindings appear in the debugger script dropdown if the debugger is open w...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: x86_64 Windows 7
: P2 normal (vote)
: Firefox 16
Assigned To: Panos Astithas [:past]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-02 18:59 PDT by (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
Modified: 2012-06-15 17:41 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch (1.79 KB, patch)
2012-06-05 02:19 PDT, Panos Astithas [:past]
rcampbell: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-06-02 18:59:59 PDT
STR:
1. Go to https://tbpl.mozilla.org/?tree=Mozilla-Inbound
2. Open Debugger using the Tools menu
3. Make a note of what the currently selected script file is.
4. Refresh the page, keeping the Debugger open
5. Notice that the currently selected script is now 'resizer.xml'.

Somehow our XBL bindings are leaking to the Debugger when the page refreshes.
Comment 1 Panos Astithas [:past] 2012-06-05 02:19:11 PDT
Created attachment 630110 [details] [diff] [review]
Patch

The patch in bug 739995 left out the case of newScript notifications, which this patch now fixes.
Comment 2 Panos Astithas [:past] 2012-06-08 06:10:42 PDT
https://hg.mozilla.org/integration/fx-team/rev/7305a888bb30
Comment 3 Tim Taubert [:ttaubert] 2012-06-09 08:38:57 PDT
https://hg.mozilla.org/mozilla-central/rev/7305a888bb30
Comment 4 Rob Campbell [:rc] (:robcee) 2012-06-11 11:21:19 PDT
Comment on attachment 630110 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature
User impact if declined: we might show some funky-looking scripts in the drop-down if we don't take this.
Testing completed (on m-c, etc.): on m-c 
Risk to taking this patch (and alternatives if risky): pretty minimal. Better checking of chrome uris in script urls.
String or UUID changes made by this patch: none.
Comment 5 Panos Astithas [:past] 2012-06-12 04:49:52 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/3c388f49c936

Note You need to log in before you can comment on or make changes to this bug.