Closed Bug 76092 Opened 24 years ago Closed 23 years ago

helper-app temp files are never deleted

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 63105

People

(Reporter: robbe, Assigned: asa)

References

Details

MIME types that are registered under Navigator/Helper Applications, and unknown
MIME types (if "open with" is selected) are handled by saving the content to a
temp file, and subsequent starting of the helper app.

These temp files are never removed; not when the helper terminates, and not when
Mozilla is closed (cleanly). Since Mozilla is the one creating them, it is also
responsible for removal.

(could be the same cause as bug 63105, but that one talks about plugins - this
here is about plain old fork'n'exec helper apps, and is therefore a much clearer
issue.)
What happens in the following scenario:

1)  I open a file in Mozilla; mozilla can't open it, so it saves it to /tmp and 
opens a helper app.
2)  I quit Mozilla without quitting the helper app.

Should Mozilla delete the file on exit?  Would that screw over helper apps that 
may not have the whole file in memory all the time?

It's arguable that the files should be deleted by Mozilla if Mozilla is still 
running when the helper quits.
I fully expect helper apps to keep the file open - that's the most natural thing
to do. Unix won't let the file die as long as there are file handles to it.

There're certainly apps that don't follow this rule, though. Example: freeamp is
happy to play from a removed file as long as you just pause/play; stopping will
close the file.

Wait ... why aren't temp files just stored in cache like everything else?
NewCache seems to hold one page per file without added metadata in that file. So
dumping it in the cache and then giving the cache file's name to the helper
would certainly work. After that, the normal logic to keep the cache size
constant is applied. What do you think?

One problem I see with this approach is that one fat mp3 could throw out a lot
of small, useful html pages; depending on how zealous eviction is.
I can reproduce this bug on RedHat 6.2 running Mozilla 0.8.1

A potential solution for Boris's question would be spawning 
sh -c "helper_app tmpfile; rm -f tmpfile". This would also solve bug #56662 and
probably bug #58667 and also allow people to use shell syntax in the helper app
specification.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 78106
Dup of Bug 63105? 
So it is.  Marking duplicate.

*** This bug has been marked as a duplicate of 63105 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.