Crash with HTML 5 video with gstreamer enabled

RESOLVED FIXED in mozilla16

Status

()

Core
Audio/Video
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Stephen Moehle, Assigned: Stephen Moehle)

Tracking

({crash})

Trunk
mozilla16
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120602202922
(Assignee)

Comment 1

5 years ago
Created attachment 629660 [details] [diff] [review]
Patch to fix gstreamer-related crash
Attachment #629660 - Flags: review?
(Assignee)

Comment 2

5 years ago
HTML 5 video crashes when gstreamer is enabled (--enable-gstreamer) since the fix for bug 714408 was checked in.

VideoData::Create() in content/media/nsBuiltinDecoderReader.cpp changed from calling PlanarYCbCrImage::SetData() to PlanarYCbCrImage::CopyData() from gfx/layers/ImageLayers.cpp. This means that the mOffset and mSkip members of YCbCrBuffer::Plane must now be set correctly.

nsGStreamerReader::DecodeVideoFrame() in content/media/gstreamer/nsGStreamerReader.cpp does not initialize either mOffset or mSkip, leading to a crash in CopyPlane() in gfx/layers/ImageLayers.cpp caused by the random values of mOffset and mSkip.

The fix is to initialize mOffset and mSkip to 0 in nsGStreamerReader::DecodeVideoFrame().
Component: General → Video/Audio

Updated

5 years ago
Attachment #629660 - Flags: review? → review?(kinetik)
Comment on attachment 629660 [details] [diff] [review]
Patch to fix gstreamer-related crash

Thanks!
Attachment #629660 - Flags: review?(kinetik) → review+
Assignee: nobody → stephen.moehle
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: checkin-needed

Updated

5 years ago
Severity: normal → critical
Keywords: crash

Updated

5 years ago
Duplicate of this bug: 761409

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b8c6c7c773c3
Keywords: checkin-needed
Target Milestone: --- → mozilla15

Comment 6

5 years ago
(This didn't make it in time for 15).
Target Milestone: mozilla15 → mozilla16
https://hg.mozilla.org/mozilla-central/rev/b8c6c7c773c3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.