Last Comment Bug 761205 - need to elaborate on "setting up phone" and how it relates to setting up an identity
: need to elaborate on "setting up phone" and how it relates to setting up an i...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Identity (show other bugs)
: unspecified
: x86 Mac OS X
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 09:58 PDT by Ben Adida [:benadida]
Modified: 2012-06-12 09:22 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
+


Attachments

Description Ben Adida [:benadida] 2012-06-04 09:58:24 PDT
Specifically, at

https://wiki.mozilla.org/Kilimanjaro/Basecamp

it says, in the use case:

"She sets up her phone which includes creating a identity account."

What does that mean exactly?
Comment 1 Dietrich Ayala (:dietrich) 2012-06-06 16:44:08 PDT
LCO should be able to provide some details here. Summary from what I understand after talking today is:

* entering of email during setup of phone (first run experience)
* prompting at first run of market, eg: "is <email> the persona you'd like to use?"
Comment 2 Larissa Co [:lco] 2012-06-06 17:01:14 PDT
Things are still up-in-the-air in terms of the UI For this. From what I understand, what I'm designing is:

* During the first run experience, the user can use Persona (enter in a new email address or one that's already associated with Persona) to sign in to the device. He isn't required to do so though.
* If the user is signed in to the device, he will have the option to use the email address he signed in with to sign in to the Marketplace App. He may also use a different email address to sign in to Marketplace and associate it with his Persona.
* If the user is not signed in to the device, the Marketplace App will ask him to sign in via Persona. (Not yet sure whether this is on launch of the Marketplace or when the user is about to purchase something.) Though the user is signed in to Marketplace, he is not signed in to the device.

One of the PMs might be able to answer the question in greater detail.
Comment 3 Dan Mills [:thunder] 2012-06-06 17:05:01 PDT
That sounds right to me.

Do you still have open questions or concerns?
Comment 4 Chris Lee [:clee] 2012-06-06 23:31:44 PDT
Sounds correct to me as well.  Thanks lco!
Comment 5 Ben Adida [:benadida] 2012-06-08 11:01:24 PDT
Dan, Chris: what is the point of signin to phone, then? If it's optional and just lets you sign into websites, isn't this just signin-to-web, and we can postpone signin-to-UA for B2G?
Comment 6 Larissa Co [:lco] 2012-06-08 11:37:09 PDT
Sadly, sign-in to phone is a paper tiger right now. The user doesn't really get anything from it because we don't have anything related to contact sync etc. But I think it's easier to just have them sign in to the device when they first get it in anticipation of other services that are coming, rather than introducing it later on, when the user has already been using the phone for a while. Just my opinion :)

Signing in to the phone also theoretically makes it easier to sign in to other apps on the phone if you're using an existing Persona that you've used on other devices, right? (I say theoretically, because you'd really have to be a power user for this to occur)
Comment 7 Dietrich Ayala (:dietrich) 2012-06-08 11:41:20 PDT
The user doesn't have to re-type their email in at the Marketplace right? (nor their billing information?) That's a benefit.
Comment 8 Dan Mills [:thunder] 2012-06-08 11:48:38 PDT
The idea is to get users set up as early as possible, so they are ready to go when they get tho the marketplace.

Up to Chris whether this is still a P1 for v1, though, I think we could drop it to a P2 with no loss of functionality (it'd be as if users skip the sign-in step on first run, they would be prompted to do it when signing into the marketplace)
Comment 9 Ben Adida [:benadida] 2012-06-12 09:21:55 PDT
ok, this feels resolved to me. We need both sign into phone and sign into web. Got it. Opening up bugs to track this.

bug 763992 tracks Identity.jsm implementation of long-term token for signin to UA.

bug 763993 tracks UX on desktop for signin-to-UA

bug 763995 tracks UX on B2G for signin-to-UA

Note You need to log in before you can comment on or make changes to this bug.