If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reposition custom menu drop-down on rotation

NEW
Unassigned

Status

()

Firefox for Android
General
5 years ago
3 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox23 affected, firefox24 affected, firefox25 affected, firefox26 affected, firefox29 affected, firefox30 affected, firefox31 affected, firefox32 affected, firefox33 affected, firefox34 affected, firefox35 affected, firefox36 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 629838 [details]
Nightly (06/04) - Screenshot

See screenshot.

--
Nightly (06/04)
Samsung Galaxy Nexus (Android 4.0.4)
On rotation, the menu button is re-inflated. BrowserToolbar can be called to reposition the popup on rotation. However, it takes time to set the custom view -- which makes the arrow not know the position of menu button. Hence, the arrow gets lost.

There are 2 options at this point:
1. WONTFIX ;)
2. close the menu popup on rotation (just like site-identity panel).
(Reporter)

Updated

5 years ago
Duplicate of this bug: 851065
(Reporter)

Updated

5 years ago
Duplicate of this bug: 851020

Comment 4

4 years ago
 I am able to reproduce this with tablets Galaxy Tab 2 and Asus Eee Transofrmers (4.1.1, 4.0.3)
status-firefox23: --- → affected
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → affected
This is still reproducible on:
32.0a1 (2014-06-02)
31.0a1 (2014-06-02)
30.0b10
29.0.1

using Asus Transformer Pad TF300T (Android 4.2.1)

Not reproducible on about:home page.
status-firefox29: --- → affected
status-firefox30: --- → affected
status-firefox31: --- → affected
status-firefox32: --- → affected
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Created attachment 8505334 [details]
device-2014-10-15-110840.png

I am still able to reproduce this issue on Asus Transformer Pad TF300T (Android 4.2.1) and Nexus 4 (Android 4.4.4).
Steps:
1. Make sure your device is in portrait orientation and navigate to a page;
2. Open the custom menu and rotate the device in landscape.

Actual result:
The custom menu is incorrectly positioned after device rotation.

Builds:
Firefox for Android 33
Firefox for Android 34 Beta 1
Firefox for Android 35.0a2 (2014-10-14)
Firefox for Android 36.0a1 (2014-10-14)

Please check the screenshot.
Status: RESOLVED → REOPENED
status-firefox33: --- → affected
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected
Resolution: WORKSFORME → ---

Updated

3 years ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.