Last Comment Bug 761231 - Font for the Debugger panels should be message-box
: Font for the Debugger panels should be message-box
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Panos Astithas [:past]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 10:46 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2012-08-03 07:17 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified


Attachments
Patch (2.76 KB, patch)
2012-06-05 02:39 PDT, Panos Astithas [:past]
no flags Details | Diff | Splinter Review
Patch v2 (2.57 KB, patch)
2012-06-05 07:09 PDT, Panos Astithas [:past]
dao+bmo: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-06-04 10:46:52 PDT
I've noticed that the font for the various panels within the Debugger is list-box, which looks pretty ugly on Windows and feels Windows 3.1-ish.

If we switch to font:message-box we'll get Segoe UI on Windows and the respective UI fonts for the other platforms as well.
Comment 1 Panos Astithas [:past] 2012-06-05 02:39:34 PDT
Created attachment 630115 [details] [diff] [review]
Patch

This should do it.
Comment 2 Dão Gottwald [:dao] 2012-06-05 02:50:12 PDT
Shouldn't this be message-box by default? What happens if you just remove font: -moz-list;?
Comment 3 Panos Astithas [:past] 2012-06-05 07:09:18 PDT
Created attachment 630156 [details] [diff] [review]
Patch v2

(In reply to Dão Gottwald [:dao] from comment #2)
> Shouldn't this be message-box by default? What happens if you just remove
> font: -moz-list;?

Good point, it looks identical. We probably used to require them when the UI was in HTML.
Comment 4 Panos Astithas [:past] 2012-06-06 02:02:54 PDT
https://hg.mozilla.org/integration/fx-team/rev/233a5180da19
Comment 5 Tim Taubert [:ttaubert] 2012-06-06 08:42:16 PDT
https://hg.mozilla.org/mozilla-central/rev/233a5180da19
Comment 6 Rob Campbell [:rc] (:robcee) 2012-06-11 11:02:03 PDT
Comment on attachment 630156 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: Fonts may look funny.
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): Style only.
String or UUID changes made by this patch:
Comment 7 Panos Astithas [:past] 2012-06-12 04:48:35 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/d2222d108e06
Comment 8 Ioana (away) 2012-08-03 07:17:47 PDT
Verified as fixed on Firefox 15.0 beta 3 (20120731150526).

Note You need to log in before you can comment on or make changes to this bug.