Last Comment Bug 761268 - GCLI has hard-coded strings (e.g. "Available commands:", "Commands starting with:")
: GCLI has hard-coded strings (e.g. "Available commands:", "Commands starting w...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: All All
: P2 normal (vote)
: Firefox 16
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 12:13 PDT by Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3
Modified: 2012-06-13 06:39 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Upload 1 (5.79 KB, patch)
2012-06-11 06:38 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
dcamp: review+
francesco.lodolo: feedback+
Details | Diff | Review

Description Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3 2012-06-04 12:13:14 PDT
http://mxr.mozilla.org/mozilla-central/source/browser/devtools/commandline/gcli.jsm#7937

getHeading: function() {
  return args.search == null ?
          'Available Commands:' :
          'Commands starting with \'' + args.search + '\':';
}

Those strings shouldn't be hard-coded.
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-06-11 06:38:09 PDT
Created attachment 631879 [details] [diff] [review]
Upload 1

Also fixed; a couple of other strings that I found while looking for similar problems, and an updated 'not found' message.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-06-11 06:38:35 PDT
https://github.com/campd/gcli/pull/49
Comment 3 Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3 2012-06-11 10:49:36 PDT
Comment on attachment 631879 [details] [diff] [review]
Upload 1

Review of attachment 631879 [details] [diff] [review]:
-----------------------------------------------------------------

Strings and l10n comments look good to me (changing from review to approval since I'm not really entitled to do a review ;-))
Comment 4 Francesco Lodolo [:flod] - OFFLINE Jun 26-Jul 3 2012-06-11 10:50:19 PDT
> changing from review to approval

approval -> feedback
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-06-12 00:38:43 PDT
https://tbpl.mozilla.org/?tree=Try&rev=d8e8d414e602
Comment 6 Tim Taubert [:ttaubert] 2012-06-13 06:39:33 PDT
https://hg.mozilla.org/mozilla-central/rev/0acca26e3763

Note You need to log in before you can comment on or make changes to this bug.