Last Comment Bug 761278 - Remove XHR.onuploadprogress
: Remove XHR.onuploadprogress
Status: RESOLVED FIXED
: addon-compat, dev-doc-complete
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Boris Zbarsky [:bz]
:
Mentors:
Depends on:
Blocks: 437381 743666
  Show dependency treegraph
 
Reported: 2012-06-04 12:43 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2015-10-18 10:49 PDT (History)
6 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
No more uploadprogress (19.49 KB, patch)
2012-07-20 19:11 PDT, Boris Zbarsky [:bz]
jonas: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-06-04 12:43:28 PDT

    
Comment 1 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-04 15:30:41 PDT
Tracking this to make sure we remove again in the next migration (or evaluate needing to apply the patch from 743666)
Comment 2 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-18 16:02:56 PDT
Assigning to bz for now - is there work to be done here now that 15 is on the Beta channel?
Comment 3 Boris Zbarsky [:bz] 2012-07-18 19:52:23 PDT
I don't think we need to track this for 15.

Basically, this bug is about removing a nonstandard feature that we've had for a while.  Firefox 14 shipped with a deprecation warning for uses of this feature.  The only question is how long we wait to remove it...

Looking at the addons mxr, I see three uses of onuploadprogress:

 /8482/content/dropioApiClient.js 
 /10550/chrome/content/ajaxUpload.js 
 /14651/chrome/content/ajaxUpload.js 

We should probably at least get those fixed before we remove it.
Comment 4 Jorge Villalobos [:jorgev] 2012-07-19 07:51:35 PDT
We can add it to the compatibility validations for whatever version this ships on, so it isn't necessary to wait for these add-ons to be fixed. We will warn them as long as a I know on which version this is happening.
Comment 5 Boris Zbarsky [:bz] 2012-07-19 07:55:30 PDT
Jorge, thanks!

Peter, any objections to removing this in 17?
Comment 6 Peter Van der Beken [:peterv] - away till Aug 1st 2012-07-19 08:13:30 PDT
Fine by me.
Comment 7 Boris Zbarsky [:bz] 2012-07-20 19:11:57 PDT
Created attachment 644562 [details] [diff] [review]
No more uploadprogress
Comment 8 Jonas Sicking (:sicking) PTO Until July 5th 2012-07-20 19:23:10 PDT
Comment on attachment 644562 [details] [diff] [review]
No more uploadprogress

Review of attachment 644562 [details] [diff] [review]:
-----------------------------------------------------------------

Yay!
Comment 11 Boris Zbarsky [:bz] 2012-07-21 20:27:52 PDT
As far as I can tell, this just triggered a rebuild of the generated events stuff somehow and _that_ just failed for whatever reason.  And is continuing to fail even with this patch backed out, since this patch had nothing to do with it to start with...
Comment 12 Boris Zbarsky [:bz] 2012-07-22 07:21:53 PDT
Relanded as http://hg.mozilla.org/integration/mozilla-inbound/rev/8fe7b1000a26
Comment 13 Ryan VanderMeulen [:RyanVM] 2012-07-22 12:44:31 PDT
https://hg.mozilla.org/mozilla-central/rev/8fe7b1000a26
Comment 14 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-23 16:08:05 PDT
untracking for 15 as per comment 3
Comment 15 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2015-10-18 10:31:40 PDT
Clearing dev-doc-needed since I didn't think any change was needed in the current XHR doc.
Comment 16 Saurabh Nair [:jsx] (not reading all bugmail. ni? if you need me) 2015-10-18 10:49:54 PDT
Apologies for triggering multiple bugmails.

Updated dev doc: https://developer.mozilla.org/en-US/Firefox/Releases/17

Note You need to log in before you can comment on or make changes to this bug.