set MOZ_PKG_SPECIAL for armv6 mozconfigs to distinguish them from armv7 android builds

RESOLVED FIXED in mozilla16

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ted, Assigned: ted)

Tracking

Trunk
mozilla16
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Currently if we start producing armv6 android builds the package name comes out the same as our existing builds. We should tack the MOZ_ARCH value onto the package name, but only if it's explicitly specified.
(Assignee)

Updated

5 years ago
Assignee: nobody → ted.mielczarek
(Assignee)

Comment 1

5 years ago
Created attachment 632765 [details] [diff] [review]
package name should include MOZ_ARCH value if it's explicitly specified

I don't actually have my Android build environment here, but I configured a Mac build --with-arch=core2 and verified that $(PACKAGE) comes out as expected.
Attachment #632765 - Flags: review?(mh+mozilla)
Comment on attachment 632765 [details] [diff] [review]
package name should include MOZ_ARCH value if it's explicitly specified

Review of attachment 632765 [details] [diff] [review]:
-----------------------------------------------------------------

I think I would be more comfortable with a completely separate variable. I don't think we need a complete configure option, but just AC_SUBSTing a variable that we'd export from mozconfig. The reason is that there is more than --with-arch that may change. As a matter of fact, we could also do armv7+neon builds, for example, which wouldn't even change --with-arch.
Attachment #632765 - Flags: review?(mh+mozilla) → review-
(Assignee)

Comment 3

5 years ago
In that case, we can just use the already-existing MOZ_PKG_SPECIAL here, since that already works in mozconfigs:
http://mxr.mozilla.org/mozilla-central/source/browser/config/mozconfigs/macosx-universal/shark#22
Summary: package name should include MOZ_ARCH value if it's explicitly specified → set MOZ_PKG_SPECIAL for armv6 mozconfigs to distinguish them from armv7 android builds
(Assignee)

Updated

5 years ago
Attachment #632765 - Attachment is obsolete: true
(Assignee)

Comment 4

5 years ago
Created attachment 633991 [details] [diff] [review]
distinguish armv6 builds from armv7 builds by changing package name

Simple, should work fine.
Attachment #633991 - Flags: review?(mh+mozilla)
Attachment #633991 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f1a89d9008c8
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/f1a89d9008c8
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
Comment on attachment 633991 [details] [diff] [review]
distinguish armv6 builds from armv7 builds by changing package name

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: can't ship ARMv6 along side ARMv7
Testing completed (on m-c, etc.): landed on m-c when it was Fx16
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #633991 - Flags: approval-mozilla-beta?
(Assignee)

Comment 8

5 years ago
This patch has zero risk to shipping builds. It only impacts the armv6 build configuration, which is only being built on trunk.
Comment on attachment 633991 [details] [diff] [review]
distinguish armv6 builds from armv7 builds by changing package name

build config only change, approving.
Attachment #633991 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.