Cannot open all Bookmarks in tabs by Middle-clicking a folder in Sidebar (Ctrl+click open in all tabs and Shift+click open all in window also do not work)

RESOLVED FIXED in Firefox 15

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: mano)

Tracking

({regression})

15 Branch
Firefox 16
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox15+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
http://hg.mozilla.org/mozilla-central/rev/dd6ec482a85d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120604030527

Steps to Reproduce:

1. Start Browser with new profile
2. Open Sidebar (Ctrl+B)
3. Expand tree and middle click a folder

Actual Results:  
  Nothing happens
  And an error appears in Error Console as follows.

Error: TypeError: tbo.view.nodeForTreeIndex is not a function
Source file: chrome://browser/content/bookmarks/sidebarUtils.js
Line: 41


Expected Results:  
  All Bookmarks in the folder should be opened in tabs

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/d0ebcaa7efb5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120603030523
Bad:
http://hg.mozilla.org/mozilla-central/rev/07d362aa2c1b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120603120904
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d0ebcaa7efb5&tochange=07d362aa2c1b



Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ddd5acd40b93
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120603032105
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b1b44a491f6a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120603055102
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ddd5acd40b93&tochange=b1b44a491f6a

Suspected; Bug 730340
(Reporter)

Updated

5 years ago
Summary: Cannot open all Bookmarks in tabs by Middle clicking afolder → Cannot open all Bookmarks in tabs by Middle clicking a folder in Sidebar

Comment 1

5 years ago
Does this for me on the bookmark toolbar, even right clicking on the folder the "open all in tabs" is greyed out too.
(Reporter)

Comment 2

5 years ago
(In reply to Grant from comment #1)
> Does this for me on the bookmark toolbar, even right clicking on the folder
> the "open all in tabs" is greyed out too.
WFM on Bookmarks Toolbar. Are you try in New profile?
Assignee: nobody → mano
Status: NEW → ASSIGNED
(Reporter)

Comment 3

5 years ago
In Sidebar, Ctrl+clcik open in all tabs and Shift+click open all in window also do not work.
Summary: Cannot open all Bookmarks in tabs by Middle clicking a folder in Sidebar → Cannot open all Bookmarks in tabs by Middle clicking a folder in Sidebar (Ctrl+clcik open in all tabs and Shift+click open all in window also do not work.)

Updated

5 years ago
tracking-firefox15: ? → +

Comment 4

5 years ago
You beat me to the bug Alice, i was just about to enter this.
Created attachment 637593 [details] [diff] [review]
patch
Attachment #637593 - Flags: review?(mak77)
Attachment #637593 - Flags: review?(mak77) → review+
http://hg.mozilla.org/integration/mozilla-inbound/rev/4d766f24e6a4
Comment on attachment 637593 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 730340 
User impact if declined: Some addons which mess with places trees could break, plus this bug.
Testing completed (on m-c, etc.): No tests for this functionality yet (will do in a follow up) 
Risk to taking this patch (and alternatives if risky): there's a one-liner alternative (QI to nsINavHistoryResultTreeViewer in tree.xml's view setter), but this shouldn't be risky.
String or UUID changes made by this patch: none.
Attachment #637593 - Flags: approval-mozilla-aurora?
Attachment #637593 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
http://hg.mozilla.org/releases/mozilla-aurora/rev/e20f71378b68
status-firefox15: --- → fixed
Target Milestone: --- → Firefox 16

Comment 9

5 years ago
https://hg.mozilla.org/mozilla-central/rev/4d766f24e6a4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 637593 [details] [diff] [review]
patch

Review of attachment 637593 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/places/content/treeView.js
@@ +50,5 @@
> +
> +  // Bug 761494:
> +  // ----------
> +  // Some addons use methods from nsINavHistoryResultObserver and
> +  // nsINavHistoryResultTreeViewer, without QIing to these intefaces first.

interfaces

Updated

5 years ago
Summary: Cannot open all Bookmarks in tabs by Middle clicking a folder in Sidebar (Ctrl+clcik open in all tabs and Shift+click open all in window also do not work.) → Cannot open all Bookmarks in tabs by Middle-clicking a folder in Sidebar (Ctrl+click open in all tabs and Shift+click open all in window also do not work)

Comment 11

5 years ago
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.