Last Comment Bug 761592 - Change search default to Google in ru localization
: Change search default to Google in ru localization
Status: RESOLVED FIXED
[qa+:simonab]
: productization
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: Firefox 16
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 763230
Blocks: 765750
  Show dependency treegraph
 
Reported: 2012-06-05 07:15 PDT by Kev Needham [:kev]
Modified: 2013-12-27 14:23 PST (History)
29 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
fixed
+
fixed


Attachments
Change search default to Google (3.87 KB, patch)
2012-06-05 07:15 PDT, Kev Needham [:kev]
l10n: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Kev Needham [:kev] 2012-06-05 07:15:32 PDT
Created attachment 630160 [details] [diff] [review]
Change search default to Google

Please change the application default for search in Firefox from Yandex to Google, per the attached patch. Google will replace Yandex as the default search engine (browser.search.defaultenginename), and will be in the first position of the search bar drop-down. Yandex will move to the second position in the search bar drop-down, and will use an updated clientID of 1909644, per Yandex.
Comment 1 Axel Hecht [:Pike] 2012-06-05 08:51:18 PDT
Comment on attachment 630160 [details] [diff] [review]
Change search default to Google

Review of attachment 630160 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, patch looks like it's doing what we want.
Comment 2 Axel Hecht [:Pike] 2012-06-05 09:51:12 PDT
At least CCing the russian bug alias, as we can't keep this bug in the right component.

Alexander, Konstantin, I'll go ahead and land this patch on central, aurora and beta. I don't want to step on your turf, but as we have the public posts out that say that we're landing this for this week's beta, we need this in quickly. Also, if we'd take this later we'd probably create yet more confusion.
Comment 4 Konstantin A. Lepikhov 2012-06-05 11:29:57 PDT
(In reply to Axel Hecht [:Pike] from comment #2)
> At least CCing the russian bug alias, as we can't keep this bug in the right
> component.
> 
> Alexander, Konstantin, I'll go ahead and land this patch on central, aurora
> and beta. I don't want to step on your turf, but as we have the public posts
> out that say that we're landing this for this week's beta, we need this in
> quickly. Also, if we'd take this later we'd probably create yet more
> confusion.
Axel, could you show the links to that public posts? We don't know the reasons of this rush. Thanks!
Comment 6 Konstantin A. Lepikhov 2012-06-05 11:49:53 PDT
(In reply to chris hofmann from comment #5)
> http://company.yandex.com/press_center/press_releases/2012/2012-06-04.xml

It's not mozilla official statement about this changes, just investor-related post in vendor's corporate blog. I mean "public posts" in community-related media.
Comment 7 Susan Chen 2012-06-05 12:31:13 PDT
Public post means the press release issued by Yandex.  Beta blog post going out this week will have information about the change.  There will be no other public post.
Comment 8 Konstantin A. Lepikhov 2012-06-05 13:08:21 PDT
(In reply to Susan Chen from comment #7)
> Public post means the press release issued by Yandex.  Beta blog post going
> out this week will have information about the change.  There will be no
> other public post.

Susan, Axel, it's very important to state this changes very clear to Firefox community. Right now it's look like one-way move driven not by users or not for users. Because there is no any discussion related to this changes or even survey like what search engine users prefer or willing to change (see http://lockshot.wordpress.com/2008/10/15/exploring-partnership-with-yandex/). I don't want to interpret this like Mozilla totally ignores interests of whole community for interests one big company.
Comment 9 Alexander L. Slovesnik 2012-06-06 04:28:06 PDT
I second Konstantin's notion. There is nothing (no blog post or arcticle) that explains this sudden change of default search engine in Firefox from most popular search provider to some other search provider. Yandex' article doesn't explain the reason for this change. Besides, it's in English only.
This situation doesn't help to build credibility and trust in Mozilla among Russian community of Firefox users.
Comment 10 Simona B [:simonab] 2012-06-06 06:53:34 PDT
Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0

Verified using Firefox 14 beta 6 ru on Win XP, Ubuntu 12.04 and Mac OS x 10.6 that:

- the default search application in Firefox is Google
- the preference browser.search.defaultenginename is Google
- Google search engine is located in the first position of the search bar drop-down 
- Yandex search engine is located the second in the search bar drop-down and uses the clientID: 1909644.
Comment 11 Mike Kaply [:mkaply] 2012-06-08 09:56:50 PDT
It seems like the questions frmo Alexander and Konstantin questions are simply being ignored?

No one from Mozilla has indicated why this change was made. Was it because of loss of revenue due to not using Google in Russia?

Or was there some less obvious reason?
Comment 12 Max 2012-06-09 00:34:10 PDT
There seems to be some missconception regarding what's a default setting and what is a user preference.
The new version will not only set Google's search for *new* users, but also change the setting upon upgrade for those who *used* the previous default setting. This seems like an intervention to user's practice and habit. Sure, there will be a possibility for users to manually change search provider back, but we all know how people "love" facing preferences, right? ;)
In fact, there is one even worse scenario. The upgrade will change the QS even for those users who might have tried another search providers and then switched back to Yandex (the default). I believe that overwriting settings that were changed by a user on purpose is a very unfriendly behaviour.
Comment 13 Alexander L. Slovesnik 2012-06-09 03:44:46 PDT
(In reply to Max from comment #12)
> There seems to be some missconception regarding what's a default setting and
> what is a user preference.
> The new version will not only set Google's search for *new* users, but also
> change the setting upon upgrade for those who *used* the previous default
> setting. This seems like an intervention to user's practice and habit. Sure,
> there will be a possibility for users to manually change search provider
> back, but we all know how people "love" facing preferences, right? ;)
> In fact, there is one even worse scenario. The upgrade will change the QS
> even for those users who might have tried another search providers and then
> switched back to Yandex (the default). I believe that overwriting settings
> that were changed by a user on purpose is a very unfriendly behaviour.

Yes, you are right.
FWIW, in Bug 364297 (change of default search provider in CJKT builds from Yahoo to Google) Mozilla has created several patches to make sure that existing user choice of default search engine has been preserved after browser update.
There is nothing like that in this bugreport :-(
Comment 14 harvey anderson 2012-06-09 13:10:02 PDT
There have been a few questions in this thread that seem to fall into two main groups: i) what’s the rationale; and ii) why wasn’t the local community consulted. I’ll try to address both here by providing more context into the decision and the process.

We recently selected Google as the default search partner for Firefox. We carefully evaluated a number of partners and determined that Google provided the best experience for the most number of people globally. These arrangements are often global in nature; consequently, we were not able to keep Yandex as the default search provider in the Firefox Russian builds.
 
This was a difficult decision and it was not done lightly. Sadly, the considerable attention and contemplation surrounding this decision is lost in the mechanics of filing a change request in bugzilla. Yandex has been a great partner. We have close ties to the individuals there and respect them personally. Yandex has made positive contributions to Firefox through its promotion and marketing and by providing innovative search solutions. We also like that Yandex provides diversity in the market because users benefit from the choice and competition they offer.

At the same time, Google has been a great partner over many years and has supported both the project and the open web in many important ways from the very beginning. Ofcourse we have our issues from time to time as they do with us, but it doesn't negate the former or the most important point - that they have a great global search product that serves the needs of most users well.  

There’s no denying that the revenues derived from integrated search and commerce services are important. They provide the means to support the global project we have today including the broad range of communities and efforts around the world. Although sustainability is a critical factor, it is however not the only factor. Google is the leading search provider worldwide. It provides a competitive offering in Russia and in almost every other region worldwide. Thus, on balance selecting Google as the default made the most sense for the most users in a way that allows the project to increase its investment in the mission through projects like the B2G mobile OS, Firefox on Android, Persona, and the web apps marketplace that aim to foster a viable, robust competitive web platform. 

The other group of questions centers around transparency. We aspire to this as an important value in how we manage the affairs of the project. In this case, both Yandex and Google are public companies and it is not always possible to share in detail the arrangements and discussions between the parties. We have no interest in violating those confidences or sharing information that could adversely impact or advantage any one party. Given these constraints, we did not deem it possible to socialize this with the community in advance as we might normally do. This is an unfortunate reality that we are bound by despite our goal to collaborate with the community as transparently as possible.  

Going forward, in Firefox Russian builds users will continue to have the option to select Yandex from the pre-installed search list. Yandex also continues to distribute a Yandex flavored version of Firefox with Yandex set as the default search. In the future we'll continue to collaborate with Yandex on new initiatives including new geos, mobile efforts, and maybe even a B2G project in the future. While I have no belief that this will convince anyone to change their opinion, I do hope that the above information better explains the situation and our intent.
Comment 15 Kev Needham [:kev] 2012-06-09 17:18:57 PDT
The preference will only be written to the user preferences file if the selected search engine is not the default.

If a user selects a search service that is not the default search engine (defined in browser.search.defaultenginename), the selectedEngine preference is written to the user preferences file. If the user selects the search engine that is defined as the app default (at the time of the selection), the selectedEngine preference is removed from the user preferences file.

The patch for this behaviour was made in 2006, and was in place when the change from Google to Yandex was made in 2009. The behavior is consistent with changes made since that time, and the specific code can be seen in https://bugzilla.mozilla.org/show_bug.cgi?id=344159. 

(In reply to Max from comment #12)
> There seems to be some missconception regarding what's a default setting and
> what is a user preference.
> The new version will not only set Google's search for *new* users, but also
> change the setting upon upgrade for those who *used* the previous default
> setting. This seems like an intervention to user's practice and habit. Sure,
> there will be a possibility for users to manually change search provider
> back, but we all know how people "love" facing preferences, right? ;)
> In fact, there is one even worse scenario. The upgrade will change the QS
> even for those users who might have tried another search providers and then
> switched back to Yandex (the default). I believe that overwriting settings
> that were changed by a user on purpose is a very unfriendly behaviour.
Comment 16 Rubén Martín [:Nukeador] 2012-06-11 06:01:40 PDT
Maybe it's better to move discussion to a better place than a bug, so I've open a topic on governance list to clarify everyone's concerns:

https://groups.google.com/forum/?fromgroups#!topic/mozilla.governance/flhYG39Ocwc

Regards.
Comment 17 Max 2012-06-13 02:16:26 PDT
Excuse me for not posting to a Google group, I don't nave a public acount there.

(In reply to Kev [:kev] Needham from comment #15)
> The preference will only be written to the user preferences file if the
> selected search engine is not the default.
Yes, that's what I'm talking about. I assume, there are users who actually use Yandex search and are happy with it. They will be forced to use another engine by default. Here (https://bugzilla.mozilla.org/show_bug.cgi?id=761592#c13) Alexander pointed to a similar case, where the previous default search engine for existing users was kept.
Comment 18 Michael 2012-06-18 13:24:34 PDT
There are two things in this bug that seem strange for me.

1. Google is not so competitive search service in Russia. It is "okay" service, but not so great as in Europe or in US.
Just compare two results pages:
http://yandex.ru/yandsearch?text=%D0%B8%D1%80%D0%BA%D1%83%D1%82%D1%81%D0%BA&lr=213 from Yandex
and
https://www.google.ru/#hl=ru&newwindow=1&output=search&sclient=psy-ab&q=%D0%B8%D1%80%D0%BA%D1%83%D1%82%D1%81%D0%BA&oq=%D0%B8%D1%80%D0%BA%D1%83%D1%82%D1%81%D0%BA&aq=f&aqi=g4&aql=&gs_l=hp.3..0l4.1187.2009.0.2084.7.5.0.2.2.1.458.1195.0j2j4-2.4.0...0.0.WddyC6gd-SQ&pbx=1&bav=on.2,or.r_gc.r_pw.r_cp.r_qf.,cf.osb&fp=c66603f521b3ab83&biw=1436&bih=694
from Google

I fancy that these example shows how exactly Google is competitive in Russia. We will tell true that it is competitve in Moscow, but outside the central region it has really strange results (but even in Moscow it us hard to find good shopping results on Google, when people in Moscow like to shop online).

I afraid that some people who used to use Yandex will not be satisfied by switching to Google. It will dissapoint users from Russian regions mostly, especially newcommers. 


2. Why should we promote a service which offers to change the browser? Just visit http://google.ru with Firefox (the page where we gonna follow our users) and take a look on this colorful promo in the top-right corner. "Open web-sites faster: install Google Chrome". 

Are you okay with that? 

Kev, don't you think that such move could harm Firefox? How can we offer service that doesn't fit our users needs and motivates them to change the browser to Google Chrome when they visit page that Firefox offers them?

Note You need to log in before you can comment on or make changes to this bug.