The default bug view has changed. See this FAQ.

[MSVC8] "dom/indexedDB/IDBCursor.cpp(42) : error C2872: 'ipc' : ambiguous symbol" after bug 666693

VERIFIED FIXED in Firefox 15

Status

()

Core
DOM: IndexedDB
P1
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: Ms2ger)

Tracking

({regression})

Trunk
mozilla16
x86
Windows Server 2003
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox15 verified)

Details

(Whiteboard: [qa-], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
See bug 666693 comment 22.

***

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=830df2eb8cec
MSVC10 SeaMonkey succeeds.

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=2c02ab33151a
MSVC8 SeaMonkey fails.
Flags: in-testsuite-
(Reporter)

Updated

5 years ago
(Reporter)

Updated

5 years ago
Depends on: 756108
(Reporter)

Comment 1

5 years ago
Created attachment 631152 [details] [diff] [review]
(Av1) Add 'mozilla::dom::indexedDB::' namespace to unconfuse MSVC8

Fixes reported (= no more, no less) errors in Try logs.

Succeeded as (SeaMonkey on MSVC8)
https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=7d0401e10421
Attachment #631152 - Flags: review?(bent.mozilla)
Comment on attachment 631152 [details] [diff] [review]
(Av1) Add 'mozilla::dom::indexedDB::' namespace to unconfuse MSVC8

Review of attachment 631152 [details] [diff] [review]:
-----------------------------------------------------------------

I really don't like all the extra goop this adds... Can we instead add a 'using namespace mozilla::dom::indexedDB::ipc;" to the top of these files, then remove the "ipc::" each place we use one of these types?
(In reply to ben turner [:bent] from comment #2)
> Comment on attachment 631152 [details] [diff] [review]
> (Av1) Add 'mozilla::dom::indexedDB::' namespace to unconfuse MSVC8
> 
> Review of attachment 631152 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I really don't like all the extra goop this adds... Can we instead add a
> 'using namespace mozilla::dom::indexedDB::ipc;" to the top of these files,
> then remove the "ipc::" each place we use one of these types?

Ben, this is completely burning us, (and all local developers on MSVC8EE which is still supported!) any chance we can land the existing patch, and do the change you suggest in a followup?

(fwiw I disagree with the disambiguity in the namespace in the first place ;-) )
(Assignee)

Comment 4

5 years ago
Created attachment 631737 [details] [diff] [review]
Bigger patch
[Checked in: Comment 6 & 9]

Pick one, please
Attachment #631737 - Flags: review?(khuey)
Attachment #631737 - Flags: review?(bent.mozilla)
Comment on attachment 631737 [details] [diff] [review]
Bigger patch
[Checked in: Comment 6 & 9]

Review of attachment 631737 [details] [diff] [review]:
-----------------------------------------------------------------

If you've verified that this compiles, r=me.
Attachment #631737 - Flags: review?(khuey) → review+
Attachment #631152 - Flags: review?(bent.mozilla) → review-
https://hg.mozilla.org/mozilla-central/rev/05842457dfdf
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 631737 [details] [diff] [review]
Bigger patch
[Checked in: Comment 6 & 9]

When this was likely a one or two line patch I had conditional-on-green a+ from alex for aurora (to get SeaMonkey/local-devs fixed) But since its bigger I figure an explicit approval is necessary.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): exposed/caused by Bug 666693
User impact if declined: MSVC8 devs cannot builds, SeaMonkey Aurora cannot build on windows.
Testing completed (on m-c, etc.): Checked into m-c today. (SeaMonkey machines have a longer end-to-end, so unsure there yet, but will hold off landing until I am sure that this fixes us)
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None
Attachment #631737 - Flags: review?(bent.mozilla)
Attachment #631737 - Flags: feedback?(bent.mozilla)
Attachment #631737 - Flags: approval-mozilla-aurora?
swapping assignee to author of accepted patch
Assignee: sgautherie.bz → Ms2ger
Comment on attachment 631737 [details] [diff] [review]
Bigger patch
[Checked in: Comment 6 & 9]

Bug 761635 - "[MSVC8] "dom/indexedDB/IDBCursor.cpp(42) : error C2872: 'ipc' : ambiguous symbol" after bug 666693" r=khuey a=khuey
(Kyle claims this is simple enough to not need a 'real' approval since its a bustage fix for SeaMonkey. -- Taking him up on that statement)

http://hg.mozilla.org/releases/mozilla-aurora/rev/bacdd7be41ff
Attachment #631737 - Flags: feedback?(bent.mozilla)
Attachment #631737 - Flags: approval-mozilla-aurora?

Updated

5 years ago
status-firefox15: affected → fixed
Whiteboard: [qa-]
(Reporter)

Updated

5 years ago
Attachment #631737 - Attachment description: Bigger patch → Bigger patch [Checked in: Comment 6 & 9]
(Reporter)

Updated

5 years ago
Attachment #631152 - Attachment is obsolete: true
(Reporter)

Comment 10

5 years ago
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey&maxdate=1339448638&hours=24&legend=0&norules=1

V.Fixed


http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey-Aurora&maxdate=1339533421&hours=24&legend=0&norules=1

firefox15: verified.
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.