Last Comment Bug 761665 - [rule view] double clicking on a property value does weird things
: [rule view] double clicking on a property value does weird things
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Dave Camp (:dcamp)
:
:
Mentors:
Depends on: 773860
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 09:33 PDT by Paul Rouget [:paul]
Modified: 2012-07-16 04:48 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
screenshot (1.64 KB, image/png)
2012-06-05 09:33 PDT, Paul Rouget [:paul]
no flags Details
v1 (6.15 KB, patch)
2012-06-18 14:29 PDT, Dave Camp (:dcamp)
paul: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Paul Rouget [:paul] 2012-06-05 09:33:43 PDT
Created attachment 630193 [details]
screenshot

STR:
- double click on a property value

The editor is followed by the plain text value.
And pressing Escape will leave the field empty.

See screenshot.
Comment 1 Paul Rouget [:paul] 2012-06-05 09:34:03 PDT
(if we can fix that in Firefox 15, that would be great too)
Comment 2 Dave Camp (:dcamp) 2012-06-05 09:49:36 PDT
Yeah, I think we need this in 15.
Comment 3 Dave Camp (:dcamp) 2012-06-18 14:29:06 PDT
Created attachment 634168 [details] [diff] [review]
v1
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-18 16:56:05 PDT
Looks like this isn't at risk of missing 15 release, nor is it a regression, so I see no need to track this. Please go ahead and nominate when it's ready for uplift.
Comment 6 Panos Astithas [:past] 2012-06-21 00:59:03 PDT
https://hg.mozilla.org/mozilla-central/rev/7808db2872b6
Comment 7 Dave Camp (:dcamp) 2012-06-26 08:29:18 PDT
Comment on attachment 634168 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 734365
User impact if declined: Clicking twice on an element in the rule view breaks the rule view
Testing completed (on m-c, etc.): Patch on m-c for about a week.
Risk to taking this patch (and alternatives if risky): Very little, it's a straightforward patch.
String or UUID changes made by this patch: None.
Comment 8 Alex Keybl [:akeybl] 2012-06-26 11:16:05 PDT
Comment on attachment 634168 [details] [diff] [review]
v1

[Triage Comment]
Regression in FF15, and low risk. Approved for Aurora 15.
Comment 9 Panos Astithas [:past] 2012-06-28 04:57:14 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/631b24920696
Comment 10 Matthew Wein [:K-9, :mattw] 2012-07-13 16:33:21 PDT
I think this bug should be linked with this one: https://bugzilla.mozilla.org/show_bug.cgi?id=773860

Note You need to log in before you can comment on or make changes to this bug.