Last Comment Bug 761742 - No script is loaded in the script debugger for me
: No script is loaded in the script debugger for me
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: unspecified
: x86 Mac OS X
: P2 normal (vote)
: Firefox 16
Assigned To: Panos Astithas [:past] (away until 7/21)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 12:03 PDT by :Ehsan Akhgari
Modified: 2012-06-25 09:56 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
WIP (6.29 KB, patch)
2012-06-14 11:06 PDT, Panos Astithas [:past] (away until 7/21)
no flags Details | Diff | Splinter Review
Patch v2 (6.17 KB, patch)
2012-06-15 06:39 PDT, Panos Astithas [:past] (away until 7/21)
no flags Details | Diff | Splinter Review
Patch v3 (6.19 KB, patch)
2012-06-15 07:47 PDT, Panos Astithas [:past] (away until 7/21)
no flags Details | Diff | Splinter Review
Patch v4 (6.30 KB, patch)
2012-06-18 09:49 PDT, Panos Astithas [:past] (away until 7/21)
dcamp: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2012-06-05 12:03:35 PDT
Almost every time I look at the script debugger, it's empty, and the drop-down box for selecting the script is turned off as well.  This happens on various web pages, which _do_ have scripts on them.  Nothing on the error console, etc.  I'm not sure what other information I need to provide here.
Comment 1 Panos Astithas [:past] (away until 7/21) 2012-06-05 12:55:27 PDT
Could it be related to the issues you described in bug 761302?
Comment 2 :Ehsan Akhgari 2012-06-05 13:20:44 PDT
(In reply to Panos Astithas [:past] from comment #1)
> Could it be related to the issues you described in bug 761302?

I'm not sure, that was the first and only time that the script debugger worked for me.  After I restarted, it stopped working again (this bug).
Comment 3 Panos Astithas [:past] (away until 7/21) 2012-06-05 22:54:51 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #2)
> (In reply to Panos Astithas [:past] from comment #1)
> > Could it be related to the issues you described in bug 761302?
> 
> I'm not sure, that was the first and only time that the script debugger
> worked for me.  After I restarted, it stopped working again (this bug).

Does it happen in a clean profile or safe mode, too? Do you have any special network configuration settings that could interfere with the debugger's fetching of the script files? Can you enable devtools.debugger.log and post or send me the console output?
Comment 4 :Ehsan Akhgari 2012-06-06 12:31:30 PDT
I have not tried on another profile.  I'm assuming that it works since nobody else is complaining about this.  ;-)

I don't have any special settings which should affect this.  Turned on devtools.debugger.log and tried again, nothing logged to the error console.
Comment 5 Panos Astithas [:past] (away until 7/21) 2012-06-06 12:47:40 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #4)
> I have not tried on another profile.  I'm assuming that it works since
> nobody else is complaining about this.  ;-)
> 
> I don't have any special settings which should affect this.  Turned on
> devtools.debugger.log and tried again, nothing logged to the error console.

Sorry, I wasn't clear, devtools.debugger.log provides dump() output, that should be visible in stdout if you start Firefox from the command line.
Comment 6 :Ehsan Akhgari 2012-06-06 12:54:32 PDT
This is what I got: https://gist.github.com/2884324
Comment 7 Panos Astithas [:past] (away until 7/21) 2012-06-06 13:03:48 PDT
From the log it looks like you opened the debugger in a page that contained the attachment from a bugzilla bug, i.e. a page without any scripts. In that case having an empty script list is normal. If you visit the actual bugzilla page and still see no scripts, then I'd like to see the new log.
Comment 8 :Ehsan Akhgari 2012-06-06 13:36:14 PDT
(In reply to Panos Astithas [:past] from comment #7)
> From the log it looks like you opened the debugger in a page that contained
> the attachment from a bugzilla bug, i.e. a page without any scripts. In that
> case having an empty script list is normal. If you visit the actual bugzilla
> page and still see no scripts, then I'd like to see the new log.

Nope, I opened it up in Gmail.
Comment 9 Panos Astithas [:past] (away until 7/21) 2012-06-06 23:53:45 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #8)
> (In reply to Panos Astithas [:past] from comment #7)
> > From the log it looks like you opened the debugger in a page that contained
> > the attachment from a bugzilla bug, i.e. a page without any scripts. In that
> > case having an empty script list is normal. If you visit the actual bugzilla
> > page and still see no scripts, then I'd like to see the new log.
> 
> Nope, I opened it up in Gmail.

Then I don't understand. The log shows that when the debugger was opened the current tab was conn0.tab58 (which is a bugzilla attachment), in which it attempted to connect and succeeded. There is no indication of connecting to one of the gmail tabs. Do you use the menu item Tools -> Web Developer -> Debugger to open the debugger or something else?
Comment 10 :Ehsan Akhgari 2012-06-07 08:32:37 PDT
I used the keyboard shortcut but that shouldn't make any difference...  This sort of suggests to me that we have a bug which causes us to select the wrong tab when the dbeugger opens up.
Comment 11 Panos Astithas [:past] (away until 7/21) 2012-06-07 09:01:08 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #10)
> I used the keyboard shortcut but that shouldn't make any difference...  This
> sort of suggests to me that we have a bug which causes us to select the
> wrong tab when the dbeugger opens up.

I always use the keyboard shortcut, too, so this makes no sense to me. Perhaps you could record a screencast for me, to see if I can find any more leads?
Comment 12 :Ehsan Akhgari 2012-06-07 10:13:45 PDT
I just press Cmd+Option+S!  Is a screencase of doing that really necessary?
Comment 13 :Ehsan Akhgari 2012-06-07 10:43:49 PDT
This is the about:support page from this profile:

https://gist.github.com/2890281
Comment 14 Panos Astithas [:past] (away until 7/21) 2012-06-07 10:57:01 PDT
As discussed in IRC, a possibly interesting information is that Ehsan has three windows open when starting the debugger. I'll try to reproduce this again tomorrow.
Comment 15 Panos Astithas [:past] (away until 7/21) 2012-06-08 02:28:27 PDT
I think I see the problem now, with multiple windows open the selected tab is not always the correct one. If we end up fixing this in bug 710258, I'll dupe it to that.
Comment 16 Panos Astithas [:past] (away until 7/21) 2012-06-14 11:06:50 PDT
Created attachment 633193 [details] [diff] [review]
WIP

The fix is simple, but the test needs more work.
Comment 17 Panos Astithas [:past] (away until 7/21) 2012-06-15 06:39:36 PDT
Created attachment 633500 [details] [diff] [review]
Patch v2

Test fixed. Try run:
https://tbpl.mozilla.org/?tree=Try&rev=ad25d7953cc6
Comment 18 Panos Astithas [:past] (away until 7/21) 2012-06-15 07:47:01 PDT
Created attachment 633523 [details] [diff] [review]
Patch v3

Slight test tweaking to avoid an orange.
Comment 19 Panos Astithas [:past] (away until 7/21) 2012-06-15 07:47:15 PDT
New try run:
https://tbpl.mozilla.org/?tree=Try&rev=9c840b41e32e
Comment 20 Panos Astithas [:past] (away until 7/21) 2012-06-18 09:49:55 PDT
Created attachment 634080 [details] [diff] [review]
Patch v4

Some oranges still. Hopefully this change will fix them:
https://tbpl.mozilla.org/?tree=Try&rev=310221f64e6d
Comment 21 Panos Astithas [:past] (away until 7/21) 2012-06-19 09:13:32 PDT
https://hg.mozilla.org/integration/fx-team/rev/3e8a7c61048a
Comment 22 Panos Astithas [:past] (away until 7/21) 2012-06-21 00:55:36 PDT
https://hg.mozilla.org/mozilla-central/rev/3e8a7c61048a
Comment 23 Panos Astithas [:past] (away until 7/21) 2012-06-22 03:19:46 PDT
Comment on attachment 634080 [details] [diff] [review]
Patch v4

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature
User impact if declined: developers with multiple browser windows open will be unable to use the debugger in some cases
Testing completed (on m-c, etc.): On m-c and fx-team
Risk to taking this patch (and alternatives if risky): this is a trivial 2-line patch, so risk is minimal
String or UUID changes made by this patch: none
Comment 24 Alex Keybl [:akeybl] 2012-06-24 13:22:23 PDT
Comment on attachment 634080 [details] [diff] [review]
Patch v4

[Triage Comment]
Low risk fix for a new dev tools feature.
Comment 25 Panos Astithas [:past] (away until 7/21) 2012-06-25 04:10:44 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/b11b719c66a0
Comment 26 :Ehsan Akhgari 2012-06-25 07:53:17 PDT
This patch did not fix the problem.  I can still reproduce.
Comment 27 Panos Astithas [:past] (away until 7/21) 2012-06-25 08:43:43 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #26)
> This patch did not fix the problem.  I can still reproduce.

Can you provide me with some logs (like in comment 6) and a screenshot of your desktop, or something that could help me identify the tabs in your open browser windows and their z-order?
Comment 28 :Ehsan Akhgari 2012-06-25 09:47:58 PDT
After some debugging over IRC, we realized that the Gecko Profiler add-on breaks the debugger.  Turning that off fixes this.
Comment 29 Benoit Girard (:BenWa) 2012-06-25 09:56:10 PDT
Sorry about that. I released an update:
https://github.com/bgirard/Gecko-Profiler-Addon/commit/7e85b232b2e814df815238989a5c93e916c2692a

Note You need to log in before you can comment on or make changes to this bug.