Last Comment Bug 761857 - Make MOZ_CRASH() stop debuggers on the line containing it (or MOZ_ASSERT) on Linux, not in abort()
: Make MOZ_CRASH() stop debuggers on the line containing it (or MOZ_ASSERT) on ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MFBT (show other bugs)
: unspecified
: All All
: -- minor (vote)
: mozilla16
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 16:47 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2012-06-07 05:51 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.75 KB, patch)
2012-06-05 16:47 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
ted: review+
Details | Diff | Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2012-06-05 16:47:02 PDT
Created attachment 630368 [details] [diff] [review]
Patch

With this change, I can't explain why the #elif defined(__APPLE__) bit is needed, since it's identical to the #else.  Is there some reason I shouldn't common up the two?

(I'm going to put the mozalloc_abort change we discussed in a separate bug, FYI.)
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-06-05 17:48:28 PDT
Comment on attachment 630368 [details] [diff] [review]
Patch

Review of attachment 630368 [details] [diff] [review]:
-----------------------------------------------------------------

Definitely merge the common cases.
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-06-06 11:28:16 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ca61695732aa
Comment 3 Ed Morley [:emorley] 2012-06-07 05:51:47 PDT
https://hg.mozilla.org/mozilla-central/rev/ca61695732aa

Note You need to log in before you can comment on or make changes to this bug.