Ensure ARM crash dump generation works in gonk

RESOLVED FIXED in mozilla17

Status

()

Toolkit
Crash Reporting
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cjones, Assigned: ted)

Tracking

(Blocks: 1 bug)

unspecified
mozilla17
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

The gonks we care about are just ARM/bionic, so the existing breakpad code should work out of the box.  But we need to verify that.
I ran b2g on my SGS2 and was able to `kill -ABRT` the b2g process and get a minidump out. I need to track down one issue though: the module debug identifiers are coming out all zeroed out.
Okay, I figured out the root cause there, I have a couple of Breakpad patches.

The first is:
http://codereview.appspot.com/6349099/
With those patches, looks good:
31  b2g!main [nsBrowserApp.cpp : 153 + 0xf]
     r4 = 0x404f3641    r5 = 0x00000000    r6 = 0x00000001    r7 = 0xbebb7bf4
     r8 = 0x00000000    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000000
     sp = 0xbebb5b18    pc = 0x0000896b
    Found by: call frame info
Created attachment 642156 [details] [diff] [review]
Breakpad tweaks to make things work properly on gonk

There was a weird bug in Breakpad's use of linux-syscall-support. We were using sys_stat (not sys_stat64) because of some NDK #defines, but that syscall apparently doesn't work in some situations (ICS? new kernel? not sure exactly). These patches have upstream review, so I'm just going to land them when I get a chance.

Comment 7

6 years ago
https://hg.mozilla.org/mozilla-central/rev/a4a0f1412b9d
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
You need to log in before you can comment on or make changes to this bug.