Popcap games don't work out-of-process in gaia

RESOLVED DUPLICATE of bug 774139

Status

RESOLVED DUPLICATE of bug 774139
7 years ago
6 years ago

People

(Reporter: cjones, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:+, blocking-basecamp:+)

Details

(Whiteboard: [games:p?])

Attachments

(1 attachment)

STR
 (1) Load "Tower Jelly" gaia app out of process.
 (2) Try to start a game.

It's possible to navigate to the "START GAME" option, but not to actually click it.  I suspect mousedown/mouseup are going through, but (click?) isn't.  Or something.

Might be a gecko event-processing bug, but dropping into B2G component first.
Created attachment 630708 [details] [diff] [review]
Gaia test

Hmmmm .... this test seems to show that onclick is being fired.

(I know this code is running out of process because console.log doesn't work :/.)
Because of bug 763340, it's possible that there's an exception being thrown that we're missing because of lack of console service.
Summary: Not delivering (onclick?) to out-of-process content → Popcap games don't work out-of-process in gaia
smaug, this bug has to be caused by some difference in the DOM events we dispatch to content in the in-process vs. out-of-process cases.  Can you suggest a good way to debug this problem?

If there's a central location that we dispatch DOM events to content from, then I'd like to log the events that are dispatched from there.  Maybe we already have that kind of logging code?
<bz> cjones: nsEventDispatcher
* dzbarsky (Adium@moz-BBE3ABD.mv.mozilla.com) has joined #content
* josh (josh@moz-7B0110AD.mv.mozilla.com) has joined #content
<bz> cjones: Log in Dispatch and DispatchDOMEvent, and you should get everything

Comment 6

6 years ago
nsEventDispatcher::Dispatch gives you all the dispatched events.

Updated

6 years ago
blocking-basecamp: --- → ?
This is a difference in behavior between same-process/cross-process event delivery that's breaking some extremely simple apps.  This should block.

Updated

6 years ago
blocking-basecamp: ? → +
blocking-kilimanjaro: --- → +

Updated

6 years ago
Blocks: 710398

Updated

6 years ago
Whiteboard: [games:p?]
(In reply to Chris Jones [:cjones] [:warhammer] from comment #7)
> This is a difference in behavior between same-process/cross-process event
> delivery that's breaking some extremely simple apps.  This should block.

This doesn't seem to be games specific at all -- just event delivery seems to be broken.  If this doesn't work, how does anything?
Felipe and I discovered that we don't dispatch raw touch events to content processes, even though |window.TouchEvent| will be nonnull.

So that's probably what's broken here!  Argh.
These guys work with the patch in bug 774139.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 774139
You need to log in before you can comment on or make changes to this bug.