Defaults to main screen in multi-monitor setup

RESOLVED DUPLICATE of bug 752149

Status

defect
RESOLVED DUPLICATE of bug 752149
7 years ago
7 years ago

People

(Reporter: lloyd1981, Unassigned)

Tracking

SeaMonkey 2.9 Branch
x86
macOS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20120312 Firefox/11.0 SeaMonkey/2.8
Build ID: 20120312221231

Steps to reproduce:

2.9.1 update - auto-update from 2.8


Actual results:

Opening positions window in primary monitor of two-monitor setup. No repositioning, opening-closing, etc. resolves.


Expected results:

Should have opened in secondary window/monitor. Never any problem with earlier versions. Firefox, Nightly, Aurora... all work correctly, resuming window location(s) and positions, sizes, etc. This issue was marked as "resolved" from 2002, but has returned. OS 10.6.8 Mac Mini dual core. I block update through prefs and still use 2.8 - too irritating and time consuming with 2.9.1.

Comment 1

7 years ago
Your bug is already reported and has been fixed in Firefox 15, see Bug 752149.
(Reporter)

Comment 2

7 years ago
(In reply to Loic from comment #1)
> Your bug is already reported and has been fixed in Firefox 15, see Bug
> 752149.

BUG IS FOR SEA MONKEY

Not Firefox. Please read and advise how I would apply a fix to Sea Monkey from Firefox? (I already use Nightly and Aurora - I would be using latest version of Firefox if that was what I wanted. Sea Monkey has unique features I use.)
(Reporter)

Comment 3

7 years ago
Do not be mislead by User Agent list. The key is the final item: Sea Monkey/2.8. 

GetInfo links to:

about:buildconfig
Source

Built from http://hg.mozilla.org/releases/mozilla-release/rev/75b17db9b6e9

Release 2.9.1 exhibits problem - NOT Firefox
(Reporter)

Comment 4

7 years ago
The build identifier for SeaMonkey 2.9.1:

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20120422 Firefox/12.0 SeaMonkey/2.9

This is the version that will not open in last closed window.

From about:config:

about:buildconfig
Source

Built from http://hg.mozilla.org/releases/mozilla-release/rev/a294a5b4f12d
Build platform
target
i386-apple-darwin10
(Reporter)

Comment 5

7 years ago
The updater indicates 2.9.1. Only "2.9" or the "prime" appears in most information locations.

Comment 6

7 years ago
>> Your bug is already reported and has been fixed in Firefox 14, see Bug 752149.

> BUG IS FOR SEA MONKEY
This fix is in core code. Firefox 15 corresponds to SeaMonkey 2.11. This will be fixed in SeaMonkey 2.11
Depends on: 752149
(In reply to Philip Chee from comment #6)
> >> Your bug is already reported and has been fixed in Firefox 14, see Bug 752149.
> 
> > BUG IS FOR SEA MONKEY
> This fix is in core code. Firefox 15 corresponds to SeaMonkey 2.11. This
> will be fixed in SeaMonkey 2.11

Correction: Firefox 15 corresponds to SeaMonkey 2.12 (which, as of this writing, is at the Aurora stage).

Lloyd: If you want, you can download the latest SeaMonkey 2.12a2 from http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-aurora/ or the latest 2.13a1 from http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk/

If either of them exhibits the bug, then it isn't fixed on SeaMonkey. If they don't, you can either start using them, or wait until 2.12 trickles down to beta stage maybe five or six weeks from now, then to release status six weeks later.
oops. Firefox *14* corresponds indeed to SeaMonkey 2.11. This subrtracts about six weeks from what I said in comment #7. I'm not sure where SeaMonkey 2.11 can be downloaded from, but maybe Philip knows.
Well, unless someone can point a 2.11 beta release, the last 2.11a2 Aurora from 4 June (three days ago) can be had from the same place as the current 2.12a2, as mentioned above.

Comment 10

7 years ago
Yes sorry I meant Firefox 14->SeaMonkey 2.11

Comment 11

7 years ago
From Bug 761887:
"This is a tracking bug for Build and Release of SeaMonkey 2.11 Beta 1
We expect an actual release on Friday 8th June."
(In reply to Philip Chee from comment #11)
> From Bug 761887:
> "This is a tracking bug for Build and Release of SeaMonkey 2.11 Beta 1
> We expect an actual release on Friday 8th June."

Ah, thanks. So the 2.11 Aurora from three days ago is the latest, until a beta1 is released (foreseen for tomorrow).
(Reporter)

Comment 13

7 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #7)
> (In reply to Philip Chee from comment #6)
> > >> Your bug is already reported and has been fixed in Firefox 14, see Bug 752149.
> > 
> > > BUG IS FOR SEA MONKEY
> > This fix is in core code. Firefox 15 corresponds to SeaMonkey 2.11. This
> > will be fixed in SeaMonkey 2.11
> 
> Correction: Firefox 15 corresponds to SeaMonkey 2.12 (which, as of this
> writing, is at the Aurora stage).
> 
> Lloyd: If you want, you can download the latest SeaMonkey 2.12a2 from
> http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-aurora/
> or the latest 2.13a1 from
> http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-
> trunk/
> 
> If either of them exhibits the bug, then it isn't fixed on SeaMonkey. If
> they don't, you can either start using them, or wait until 2.12 trickles
> down to beta stage maybe five or six weeks from now, then to release status
> six weeks later.

A "10.0" update appeared. No good. Too long to download. Installed 2.10 as direct download. No good. Skipped 11. 12 - too long for download. But thanks for the link because 2.13a1 opened in secondary monitor, same place, same size as 2.8. Have not had chance to review. (Drop menu of tabs now in italic.) 

Will follow releases as well as "nightlys" Will see if things remain the same.

Thank you all for your help.
(Reporter)

Comment 14

7 years ago
Have not compared stylesheets, but the font for this section (text boxes) is pretty gruesome (appears to be Bold Courier), while the drop menu for tabs is now italic.

Comment 15

7 years ago
1. Looks like normal courier to me. You should file a new bug with a screenshots for this.

2. Only the menu items for tabs scrolled off the window should be in italics. Menu items for tabs visible in the tabbar should be normal non-italic, non-bold, non-anything-else.
(Reporter)

Comment 16

7 years ago
Reinstalled and the tab menu listing performs correctly. In 2.8 and 2.9, the text box font was my standard plain font, Verdana, set at 16 pts for the HD 23" monitor I use for the second screen. Since the font menu is simple alpha text listing, it is impossible to determine which style of font is selected (Prefs do not allow for bolding, italic, etc.) Plain "Courier" displays Bold. Courier CE works fine, while Courier New simply fades into a medium grey.

Will keep track of through other pages before posting bug.
(Reporter)

Comment 17

7 years ago
Latest build, nightly 2.13a1 Build 20120608003003 just installed with no issues. It appears the window location issue has been resolved.
(Reporter)

Comment 18

7 years ago
Sorry for multiples on same day. There IS an issue with fonts: ALL "comments" boxes of all sites recently visited render type entry in Courier Bold. Will post bug report. It appears THIS issue, re: window location, resolved.

Updated

7 years ago
Duplicate of this bug: 763322

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
No longer depends on: 752149
Resolution: --- → DUPLICATE
Duplicate of bug: 752149
You need to log in before you can comment on or make changes to this bug.