The default bug view has changed. See this FAQ.

zimbra email not showing some email subjects

VERIFIED FIXED in mozilla16

Status

()

Core
JavaScript Engine
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: dietrich, Assigned: luke)

Tracking

({regression})

Trunk
mozilla16
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
screenshot: http://cl.ly/1i342i3w0l1Q06111h1X
(Reporter)

Comment 1

5 years ago
Taras said it's a bug in Nightly.
Assignee: server-ops → nobody
Group: infra
Component: Server Operations → General
Product: mozilla.org → Firefox
QA Contact: phong → general
Version: other → unspecified
(Reporter)

Updated

5 years ago
Keywords: regression

Updated

5 years ago
Version: unspecified → Trunk

Updated

5 years ago
Duplicate of this bug: 762131
(Reporter)

Comment 3

5 years ago
Downgrading to 16.0a1 (2012-06-05) fixes the problem.
(Reporter)

Comment 4

5 years ago
aka http://hg.mozilla.org/mozilla-central/rev/a7a905fd70d5
I'm experiencing the same issue with the same build.
Duplicate of this bug: 762061
Range between the two Nightlies:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a7a905fd70d5&tochange=6338a8988917
Keywords: regressionwindow-wanted
mozilla-central range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a7a905fd70d5&tochange=c76497029f0d

Came from the inbound merge, so inbound range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=577a88fc97b6&tochange=b7fb3d52c843

Caused by bug 659577.
Assignee: nobody → general
Blocks: 659577
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Keywords: regressionwindow-wanted
OS: Other → All
I've attempted a backout of the main bug 659577 landing and the followup commit, but there are conflicts with things that landed after, so think it's perhaps just safer to leave for Luke to take a look at for now.
(Assignee)

Comment 10

5 years ago
Yes, I'll look at it immediately.
(Assignee)

Comment 11

5 years ago
Phew, I've tracked it down to a bug in the mjit changes: increment on a formal argument when formals are aliased by 'arguments' (but not by the scope chain) doesn't increment the canonical slot in the arguments object and so is effectively a nop.

Should be a simple fix; writing mjit patches isn't a good idea at this hour so I'll do it tomorrow.
(Assignee)

Comment 12

5 years ago
Created attachment 630901 [details] [diff] [review]
fix and test

Actually, the fix is pretty simple.
Assignee: general → luke
Status: NEW → ASSIGNED
Attachment #630901 - Flags: review?(dvander)
Attachment #630901 - Flags: review?(dvander) → review+
(Assignee)

Comment 13

5 years ago
https://hg.mozilla.org/mozilla-central/rev/7e4c2abb9fc9
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
Nightlies retriggered on 7e4c2abb9fc9.
Verified fixed with the new Nightly - thanks! :-)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1
http://hg.mozilla.org/mozilla-central/rev/7e4c2abb9fc9
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.