If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

all calendars are empty if SPDY is enabled and using Provider for Google Calendar extension

UNCONFIRMED
Unassigned

Status

Calendar
Lightning Only
--
major
UNCONFIRMED
5 years ago
2 years ago

People

(Reporter: Jos Zonneveld, Unassigned)

Tracking

Lightning 1.5

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

Upgraded to Thunderbird 13.0 (dutch).
Lightning upgraded to 1.5.(english only, known issue)


Actual results:

After upgrade all my calendars are empty.
Tried to remove and add a calendar, but it is keeps showing nothing.
Downgraded to thunderbird 12+lightning 1.4, all my calendars are working again


Expected results:

Calendars working as in last version (1.4)
(Reporter)

Updated

5 years ago
Severity: normal → blocker
Are there any calendar related errors shown in Tools -> Error Console? What types of calendars are you using (local storage, .ics file, CalDAV, etc.)?
(Reporter)

Comment 2

5 years ago
Reinstalled TB 13.

There are no errors, some warnings and messages, but none of them are calendar related.
Al the calendars are Google ics calendars.
Please set the preference "calendar.debug.log" to true (from the Thunderbird Preferences dialog, Advanced, General tab, Config Editor...), and you should get some messages in the Error Console that start with "[calICSCalendar]".
(Reporter)

Comment 4

5 years ago
done,
still no errors, but I can seen a lot of traffic in the "messages" view.
It seems that items are fetched from google, but nothing is displayed.
[calGoogleCalendar] Requesting GET https.....
[calGoogleCalendar] Adding item ..... to queue
Is this problem related to the fact that this version is not yet translated to dutch???

Comment 5

5 years ago
Have you actually enabled the calendars to display, i.e. is the checkbox next to the calendar name ticked? Do you use the offline cache? Does enabling or disabling changes anything?

Does it work with non Google calendars, e.g. from https://www.mozilla.org/projects/calendar/holidays.html ? Thunderbird uses the SPDY protocol by default that was created by Google and is used on Google servers. You could test with SPDY disabled by setting "network.http.spdy.enabled" to "false".
(Reporter)

Comment 6

5 years ago
The holidays calendar works.
After this I changed network.http.spdy.enabled to false, and all the calendars are displayed then.
Adding an event is also working now.

All the calendars I uses are from Google, so SPDY switched on, should have worked?

Comment 7

5 years ago
Maybe the SPDY implementation in Firefox/Thunderbird is faulty.

If you added an event to the Google Calendar it means you are not using the ics feed from Google Calendar because that is read-only. To get write access you are either using the Provider for Google Calendar extension or the CalDAV provider. Which one do you use?
(Reporter)

Comment 8

5 years ago
I'm using the Provider for Google Calendar extension.

Updated

5 years ago
Summary: After upgrade to 1.5, all calendars are empty → all calendars are empty if SPDY is enabled and using Provider for Google Calendar extension

Comment 9

5 years ago
Patrick, you did helped with Bug 727943. Could you take a look at this problem too?

This times it is about SPDY + Thunderbird 13 + Lightning 1.5 and accessing Google Calendar using the Provider for Google Calendar extension <https://addons.mozilla.org/thunderbird/addon/provider-for-google-calendar/>
Stefan, I'll definitely take a look - but I'm on vacation for the next 10 days or so, so please be patient.

The most helpful thing for me, being largely unfamiliar with lightning and gthe gcal extension mentioned above, would be a very detailed STR. Thanks!

Comment 11

5 years ago
Jos, I cannot reproduce your problem using Thunderbird 13, Lightning 1.5, Provider for Google Calendar 0.13, SPDY enabled. Seems to work just fine. Maybe there is some other extension or some other setting in your profile that affects this.
(Reporter)

Comment 12

5 years ago
Tried to switch off all the extensions, except of Ligthning and Provider for Google Calendar extension.
But with SPDY enabled, the problem remains.

How can I give you the info to resolve this issue?
jos - start with this
https://developer.mozilla.org/en/HTTP_Logging
(Reporter)

Comment 14

5 years ago
Created attachment 632678 [details]
http log

log file starting and closing of thunderbird with spdy enabled
(Reporter)

Comment 15

5 years ago
Comment on attachment 632678 [details]
http log

domainname changed to mydomain.com
there is 1 spdy transaction, which is a gatewayed http transaction. it has 818 bytes of text/plain in it which appears to be delivered to the caller. Everything looks ok from the spdy pov to me.

can you provide a more detailed view on why the applicaiton is not working?
(Reporter)

Comment 17

5 years ago
Tell me what you need
Maybe Stefan can answer.. all I can say is that data is flowing with spdy. I don't know anything about calendaring to tell you if it is the right data or not.

Comment 19

5 years ago
I'm not able to reproduce the reported problem as written in Comment 11. Maybe it's related to specific Thunderbird settings or specific network/proxy configurations?

Jos, could you test if you can reproduce the problem in a new Thunderbird test profile?
(Reporter)

Comment 20

5 years ago
This took more than I expected.
I removed the profile, created a new one, but it was not possible to create an account??(No errors, just no action after click "add account")
Removed and reinstalled TB13, same problem.
Installed TB12, created 1 account.
Updated TB12 to TB13, and now it was possible to create more accounts???.
Installed Lightning and Provider for Google Calendar extensions.
Added the calendars, and now they are showing, with SPDY enabled.

So the calendar problem was a glitch in my profile?.
The strange thing it was, that the same profile was working in TB12?

Thanks to all, who took the time to work this out.

Comment 21

5 years ago
Now it would be interesting to compare both profiles and identify what setting in combination with SPDY caused the problem. First try could be to compare the output from Help > Troubleshooting Information or the content of prefs.js.
Severity: blocker → major
(Reporter)

Comment 22

5 years ago
The output of "Troubleshooting Information", did not give me a clue.
The prefs.js of the previous profile got twice the items compared to the new one.
There are no lines in both prefs.js, containing the word "spdy"
Do you have a suggestions where to look for?
You need to log in before you can comment on or make changes to this bug.