Last Comment Bug 762250 - Receipts aren't exposed as an App property
: Receipts aren't exposed as an App property
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: DOM: Apps (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Andy McKay [:andym]
:
Mentors:
Depends on:
Blocks: 553102
  Show dependency treegraph
 
Reported: 2012-06-06 14:18 PDT by Ed Lee :Mardak
Modified: 2012-07-28 09:32 PDT (History)
6 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add in receipts to the __exposedProps__ (675 bytes, patch)
2012-06-08 10:56 PDT, Andy McKay [:andym]
fabrice: review+
Details | Diff | Review

Description Ed Lee :Mardak 2012-06-06 14:18:49 PDT
Not sure why dom/tests/mochitest/webapps/test_install_receipts.xul isn't failing because it shouldn't be able to access pending.result.receipts
Comment 1 Ed Lee :Mardak 2012-06-06 15:05:49 PDT
Oh I see why it isn't failing..

p = navigator.mozApps.install("http://ed.agadak.net/manifest.webapp", {receipts: ["Woot!"]}); p.onsuccess = function() console.log("success", this.result.receipts); p.onerror = function() console.log("error");

Doing that from content pages runs onsuccess but receipts is undefined. Doing that from about: (chrome privileged page) works okay.
Comment 2 [:fabrice] Fabrice Desré 2012-06-06 15:27:34 PDT
yes, we forgot to add |receipts| to __exposedProps__
Comment 3 Andy McKay [:andym] 2012-06-08 10:56:42 PDT
Created attachment 631460 [details] [diff] [review]
Add in receipts to the __exposedProps__
Comment 4 [:fabrice] Fabrice Desré 2012-06-08 11:07:03 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/c75aedd63695
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-06-09 19:12:08 PDT
https://hg.mozilla.org/mozilla-central/rev/c75aedd63695
Comment 6 Andy McKay [:andym] 2012-06-11 14:10:16 PDT
Working for me in nightly, thanks.

Note You need to log in before you can comment on or make changes to this bug.