If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

-moz-transform: translate unexpected behavior for textarea

RESOLVED DUPLICATE of bug 703241

Status

()

Core
General
RESOLVED DUPLICATE of bug 703241
5 years ago
5 years ago

People

(Reporter: k.tsabolov, Unassigned)

Tracking

13 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.54 Safari/536.5

Steps to reproduce:

Typed into textarea which was positioned using CSS property -moz-transform: translate()


Actual results:

On each key press (except keys that don't represent visible input) document scrolls to the place where textarea must appear without CSS transformations.

Please take a look at the test case — http://jsfiddle.net/H9vLq/


Expected results:

Must be taken into account that textarea (or its parent) was positioned using CSS3 transformations and scroll (or do nothing) document accordingly.
Component: Untriaged → General
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: untriaged → general
Sounds like basically bug 703241.
Depends on: 703241
(Reporter)

Comment 2

5 years ago
Yeah, Exactly the same behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703241
You need to log in before you can comment on or make changes to this bug.