Last Comment Bug 762425 - B2G 3G is not setup properly after toggle on/off
: B2G 3G is not setup properly after toggle on/off
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla16
Assigned To: Kan-Ru Chen [:kanru] (UTC+8)
:
Mentors:
Depends on:
Blocks: b2g-3g
  Show dependency treegraph
 
Reported: 2012-06-07 03:45 PDT by Kan-Ru Chen [:kanru] (UTC+8)
Modified: 2012-06-20 08:02 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Always reconfigure network if found connected interface (1.30 KB, patch)
2012-06-20 01:10 PDT, Kan-Ru Chen [:kanru] (UTC+8)
philipp: review+
Details | Diff | Review

Description Kan-Ru Chen [:kanru] (UTC+8) 2012-06-07 03:45:44 PDT
After boot:

  root@android:/ # cat /proc/net/route
  Iface   Destination     Gateway
  rmnet0  00000000        0158506F
  rmnet0  0058506F        00000000

Toggle off/on:

  Iface   Destination     Gateway
  rmnet0  0058506F        00000000

I think it is because 3G is never a preferred connection type.
Comment 1 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-20 01:10:07 PDT
Created attachment 634810 [details] [diff] [review]
Always reconfigure network if found connected interface

Could we auto-test this?
Comment 2 Philipp von Weitershausen [:philikon] 2012-06-20 01:16:50 PDT
Comment on attachment 634810 [details] [diff] [review]
Always reconfigure network if found connected interface

Review of attachment 634810 [details] [diff] [review]:
-----------------------------------------------------------------

Going to take this review off mrbkap's plate. I'm to blame for any bugs in NetworkManager, anyway, so this is my chance to redeem myself. ;)
Comment 3 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-20 01:23:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b51d1f7011fc
Comment 4 :Ehsan Akhgari (out sick) 2012-06-20 08:02:12 PDT
https://hg.mozilla.org/mozilla-central/rev/b51d1f7011fc

Note You need to log in before you can comment on or make changes to this bug.