Update Migration schema check to Places v21

RESOLVED FIXED in Firefox 14

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gcp, Unassigned)

Tracking

Trunk
Firefox 16
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14+ fixed, firefox15+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The places schema was changed in Firefox 14.

For Native Fennec release, users will be (should be?) on Firefox 10.x when they upgrade, and they will have a schema version in the range 12-20. Native Fennec checks if the Places version is supported before allowing an upgrade.

Because it was increased in XUL beta 14, beta users transitioning to native currently will no longer be able to migrate their data.

This increases the version check to support the changes in 14. The actual schema changes are inconsequential for Native Fennec.
(Reporter)

Comment 1

5 years ago
Created attachment 630952 [details] [diff] [review]
Patch 1. Update version check

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 720081
User impact if declined: Beta users will lose history/bookmarks
Attachment #630952 - Flags: review?(mark.finkle)
Attachment #630952 - Flags: approval-mozilla-aurora?
(Reporter)

Updated

5 years ago
Depends on: 720081
(Reporter)

Comment 2

5 years ago
Comment on attachment 630952 [details] [diff] [review]
Patch 1. Update version check

The breaking bug was committed to m-a but that is in m-b by now.
Attachment #630952 - Flags: approval-mozilla-beta?
Attachment #630952 - Flags: review?(mark.finkle) → review+
(Reporter)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a281462f3f4e
https://hg.mozilla.org/mozilla-central/rev/a281462f3f4e

(Merged by Ed Morley)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16

Comment 5

5 years ago
Comment on attachment 630952 [details] [diff] [review]
Patch 1. Update version check

We shouldn't need this for our FN14.0 release, but we do need it on the beta channel prior to FN15's uplift. Given that, let's only land on tip of mozilla-beta (as well as mozilla-aurora).
Attachment #630952 - Flags: approval-mozilla-beta?
Attachment #630952 - Flags: approval-mozilla-beta+
Attachment #630952 - Flags: approval-mozilla-aurora?
Attachment #630952 - Flags: approval-mozilla-aurora+

Updated

5 years ago
tracking-firefox14: --- → +
(Reporter)

Comment 6

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e828f1a097f6
https://hg.mozilla.org/releases/mozilla-beta/rev/933fb045fb04
status-firefox14: --- → fixed
status-firefox15: --- → fixed
tracking-firefox15: --- → +
You need to log in before you can comment on or make changes to this bug.