Closed Bug 76253 Opened 19 years ago Closed 14 years ago

Page source of an attached image can not be viewed

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows NT
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: marina, Assigned: neil)

References

Details

(Keywords: fixed-seamonkey1.1a)

Attachments

(4 files, 3 obsolete files)

**** observed with 2001-04-16 build ****
Steps to reproduce:
- attach an image file to the message;
- get message, open the attachment from the envelope in the browser;
- go View|Page source;
//note: page source is blank and browser tries to open/save the attachment again
This sounds like the same problem as bug 84542.
I've got a patch that adds a "View Source" item to the attachment menus,
if you're interested.
Attached patch Proposed patch (obsolete) — Splinter Review
I got a bit carried away...
* Added View Source to all attachment menus
* Added a special menu for a single attachment
* Created the attachment submenus lazily
* Removed individual command handlers
* Rewrote the backend not to use eval
Attached patch Rest of patch :-) (obsolete) — Splinter Review
QA Contact: esther → trix
Attached patch bitrotSplinter Review
Attachment #65014 - Attachment is obsolete: true
Attached patch bitrotSplinter Review
Attachment #65016 - Attachment is obsolete: true
This sounds like a dupe of bug 84542 to me.
No, my patch correctly views the page source of any attachment in the list.
Product: Browser → Seamonkey
Assignee: sspitzer → mail
(In reply to comment #0)
> **** observed with 2001-04-16 build ****
> Steps to reproduce:
> - attach an image file to the message;
> - get message, open the attachment from the envelope in the browser;
> - go View|Page source;
> //note: page source is blank and browser tries to open/save the attachment again

why would it not be blank? 

view source displays attachment source in mail front end.
so is this bug still needed?

Well I guess the underlying bug is WORKSFORME these days and parts of the patch have already been checked in although I still find it convenient to be able to view the source of a file that has been attached with the wrong MIME type. Mnyromyr, do you think I should resurrect any parts of comment 4?
The original bug description as such is WFM now, since you can't do "View|Page source" anymore in this particular case...

But in the case of mail attachments it's still useful to able to see the decoded source, so a View Source (context) menuitem would be a nice-to-have.
Attached patch Proposed patch (obsolete) — Splinter Review
* Adds a view source menuitem to the context menu
* Creates the file attachment submenus lazily
* Clones the context menuitems to save duplication on entities
* Makes deleted attachments display in the file submenu
* Fixes a strict JS warning
Assignee: mail → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
Attachment #207916 - Flags: review?(mnyromyr)
Comment on attachment 207916 [details] [diff] [review]
Proposed patch

Looks good.
Attachment #207916 - Flags: review?(mnyromyr) → review+
Attachment #207916 - Attachment is obsolete: true
Attachment #214475 - Flags: superreview?(bienvenu)
Comment on attachment 214475 [details] [diff] [review]
Fix view source of detached attachment

nice
Attachment #214475 - Flags: superreview?(bienvenu) → superreview+
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Attachment #214475 - Flags: approval-seamonkey1.1a?
Comment on attachment 214475 [details] [diff] [review]
Fix view source of detached attachment

a=me for SM1.1a
Attachment #214475 - Flags: approval-seamonkey1.1a? → approval-seamonkey1.1a+
Fixed checked in to the branch.
You need to log in before you can comment on or make changes to this bug.