Last Comment Bug 762617 - URL classifier components are installed depending on safe browsing
: URL classifier components are installed depending on safe browsing
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 12:00 PDT by Mike Hommey [:glandium]
Modified: 2012-06-12 03:07 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
affected


Attachments
Install URL classifier components when MOZ_URL_CLASSIFIER is set (957 bytes, patch)
2012-06-07 12:08 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-06-07 12:00:07 PDT
URL classifier can be enabled without safe browsing enabled, yet, the components are only installed when safe browsing is enabled. While this can sound like a theoretical problem, as I'm using the browser package-manifest to package xulrunner, and as the url classifier is enabled in xulrunner, but not safe browsing (since safe browsing is part of browser/), it is a problem for me that the url classifier components are not installed.
Comment 1 Mike Hommey [:glandium] 2012-06-07 12:08:21 PDT
Created attachment 631072 [details] [diff] [review]
Install URL classifier components when MOZ_URL_CLASSIFIER is set
Comment 3 Graeme McCutcheon [:graememcc] 2012-06-12 03:07:21 PDT
https://hg.mozilla.org/mozilla-central/rev/03098cbeb2ba

Note You need to log in before you can comment on or make changes to this bug.