Closed Bug 762650 Opened 9 years ago Closed 9 years ago

SPDY pages won't load when network.http.keep-alive is set to false

Categories

(Core :: Networking: HTTP, defect)

13 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox13 - affected
firefox14 --- unaffected
firefox15 --- unaffected
firefox16 --- unaffected

People

(Reporter: philipp, Assigned: mayhemer)

Details

(Whiteboard: [spdy])

Attachments

(1 file)

users in the SUMO forums have reported that sites served via SPDY won't load when network.http.keep-alive is set to false. users affected, who have provided system details are on firefox 13 and vista & win7 (32bit as well as 64bit), but the sample size is still small atm. 

this can be reproduced with a clean profile.
* set network.http.keep-alive to false
* load https://www.google.com and https://twitter.com (will load partly but never finish connecting)

SUMO-user reports can be found her for example:
https://support.mozilla.org/questions/928182#answer-339391
https://support.mozilla.org/de/questions/928888
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 762162
Philipp - thanks! I'm going to keep this open to specifically address the keep-alive issue. 762162 might be something else and we can address that over there.
Status: RESOLVED → REOPENED
Component: Networking → Networking: HTTP
Ever confirmed: true
QA Contact: networking → networking.http
Resolution: DUPLICATE → ---
Whiteboard: [spdy]
I can make this happen on linux nightly.. now.. it takes a few force reloads more than windows, but its there. That's good - we haven't had a OS specific spdy issue yet :)
Assignee: nobody → mcmanus
STR:
- FX13
- clean profile
- run FX
- about:config: http.keep-alive = false
- search "gmail"
- click the gmail link
- log in with "remember" on
- (save password)
=> hang

Irreproducible on FX14 (beta).

In the log after the final redirect to mail.google.com/mail/?hl-cs&shva=1 (while there is already an existing SPDY session to that host) I can see:

2012-06-08 22:14:18.505000 UTC - 3492[220f640]: nsHttpConnectionMgr::GetConnection [ci=.S.mail.google.com:443 caps=20]
2012-06-08 22:14:18.505000 UTC - 3492[220f640]:   adding transaction to pending queue [trans=f5d3e20 pending-count=1]

Build release channel to figure this out.
Status: REOPENED → NEW
Regression from bug 739522 (https://hg.mozilla.org/releases/mozilla-release/rev/abd73853ffc3)

nsHttpConnectionMgr::GetConnection returns null for case of keep-alive = false (=> trans->Caps() & NS_HTTP_ALLOW_KEEPALIVE == 0) and active SPDY session that just pushes the transaction to pending queue.

On beta, the code has radically changed in bug 599164, so it's unreproducible on FX14+.  My proposal is actually what we now have on beta.

Options:
- since keep-alive = false is non-standard, WONTFIX 
- take the patch on release channel (unrealistic)
- disable SPDY on release (also unrealistic)
Assignee: mcmanus → honzab.moz
Status: NEW → ASSIGNED
First, thanks honza!

Honza and I disagreed on whether this was producible on 14/15/16 (we agreed it was on 13). After retesting I now agree with honza.

I agree with assessment of the basic problem (including the patch here) and that the code on FF14 effectively does that already as a by product of the HTTP pipeline patches. Drivers can decide if thy would like the code on FF13 in case a chemspill release is made - but my opinion is that this bug does not merit one because it is only an issue in conjunction with a non-standard preference.
(In reply to Honza Bambas (:mayhemer) from comment #5)
> - since keep-alive = false is non-standard, WONTFIX 

Given this, not tracking for FF13.
Already works on >= 14 and is a non standard pref on FF13 unworthy of chemspill. Nothing more to do here.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.