Last Comment Bug 762654 - Switch the 2d canvas context to new DOM bindings
: Switch the 2d canvas context to new DOM bindings
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Peter Van der Beken [:peterv]
:
Mentors:
Depends on: 756258 761772 762651 762652 762657 769080 776242
Blocks: 746773
  Show dependency treegraph
 
Reported: 2012-06-07 13:31 PDT by Peter Van der Beken [:peterv]
Modified: 2012-07-28 22:00 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (14.15 KB, patch)
2012-06-07 13:40 PDT, Peter Van der Beken [:peterv]
no flags Details | Diff | Review
v1.1 (17.17 KB, patch)
2012-06-25 14:32 PDT, Peter Van der Beken [:peterv]
bzbarsky: review+
Details | Diff | Review

Description Peter Van der Beken [:peterv] 2012-06-07 13:31:48 PDT

    
Comment 1 Peter Van der Beken [:peterv] 2012-06-07 13:40:37 PDT
Created attachment 631113 [details] [diff] [review]
v1
Comment 2 :Ms2ger 2012-06-08 00:08:45 PDT
Comment on attachment 631113 [details] [diff] [review]
v1

Review of attachment 631113 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/Makefile.in
@@ +128,5 @@
>  
>  LOCAL_INCLUDES += \
>  		-I$(topsrcdir)/js/xpconnect/src \
>  		-I$(topsrcdir)/js/xpconnect/wrappers \
> +		-I$(topsrcdir)/content/canvas/src \

Why's that?
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-06-20 05:25:46 PDT
FWIW we're getting pretty close to being able to remove nsCanvasRenderingContext2D, if that helps here.
Comment 4 Peter Van der Beken [:peterv] 2012-06-25 14:32:17 PDT
Created attachment 636489 [details] [diff] [review]
v1.1

This makes the pref for Azure canvas static, so requiring a restart after changing it.
I had to make nsIDOMCanvasRenderingContext2D_GetImageData a custom quickstub because ImageData is a non-wrappercached object with a new binding.
Comment 5 Boris Zbarsky [:bz] 2012-06-25 14:38:09 PDT
Comment on attachment 636489 [details] [diff] [review]
v1.1

r=me
Comment 6 Peter Van der Beken [:peterv] 2012-06-27 07:50:59 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d6f341e77b68
Comment 7 Matt Brubeck (:mbrubeck) 2012-06-27 16:28:00 PDT
Sorry, I backed this out on inbound along with bug 762652 because Windows PGO builds were crashing in gfxContext::FillAzure:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9a2cc88619ba

https://tbpl.mozilla.org/php/getParsedLog.php?id=13051005&tree=Mozilla-Inbound
Comment 8 Peter Van der Beken [:peterv] 2012-06-30 02:57:34 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/9feb8257666c
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-06-30 12:41:46 PDT
https://hg.mozilla.org/mozilla-central/rev/9feb8257666c

Note You need to log in before you can comment on or make changes to this bug.