Closed Bug 762724 Opened 10 years ago Closed 10 years ago

Tabs button should merge with the Tabs UI when tabs are shown

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox15 verified)

VERIFIED FIXED
Firefox 16
Tracking Status
firefox15 --- verified

People

(Reporter: sriram, Assigned: sriram)

References

Details

Attachments

(2 files)

As a part of new design, the tabs button should merge with the tabs UI's dark background.

This requires newer resources on mdpi, hdpi and xhdpi scales.
Blocks: 739407
To avoid spamming:
This should also take care of the arrow to express the toggle behavior.
This requires newer resources.

My patch posted in bug 739407 has the required plumbing for this.
However, the arrows dont change orientation! (Android! I hate you!)
This adds 2 more button states to tabs button, to make it feel complete in expanded view.
Assignee: nobody → sriram
Attachment #632157 - Flags: review?(mark.finkle)
This patch adds (more) resources to change the direction of the arrow, based on open/close state of tabs UI.
Attachment #632436 - Flags: review?(mark.finkle)
Attachment #632436 - Flags: review?(mark.finkle) → review+
Attachment #632157 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 764732
https://hg.mozilla.org/mozilla-central/rev/086c2e7be28a
https://hg.mozilla.org/mozilla-central/rev/b993b4812103
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Comment on attachment 632157 [details] [diff] [review]
Patch (1/2): Button change

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: Fills the entire tab-button to merge with tabs UI
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: -
Attachment #632157 - Flags: approval-mozilla-aurora?
Comment on attachment 632436 [details] [diff] [review]
Patch (2/2): Arrow directions

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: Adds an arrow pointing the direction the tabs-ui will expand/collapse. This will be lost without this patch.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): None. 
String or UUID changes made by this patch:
Attachment #632436 - Flags: approval-mozilla-aurora?
Comment on attachment 632157 [details] [diff] [review]
Patch (1/2): Button change

[Triage Comment]
Tablet UI bugs are approved for Aurora 15, as they carry little risk to mobile and none to desktop.
Attachment #632157 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #632436 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Alex Keybl [:akeybl] from comment #9)

Errant mass modify. This remains approved, however. We'll back the tabs feature out if it poses significant issues before Beta.
The number of tabs and arrow is not displayed on the latest Nightly but this is covered in Bug 773181. The tabs button is merged when the tab menu is opened and the arrows are correct on Aurora. Marking as verified.

Verified on:
Nightly 16.0a1 2012-07-11/Aurora 15.0a2 2012-07-11
HTC Desire
Android 2.2.2
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.