Large text files are not printed entirely

RESOLVED DUPLICATE of bug 717178

Status

()

defect
RESOLVED DUPLICATE of bug 717178
7 years ago
7 years ago

People

(Reporter: simona.marcu, Unassigned)

Tracking

({regression})

Trunk
All
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120607 Firefox/15.0a2

Large text files are not entirely printed. The Printing dialog gets stuck at 96%.  

Reproducible: always

Steps to reproduce:
1. Open and Print:
http://mozqa.com/data/firefox/awesome_bar/diff.txt

Expected results:
After selecting to print, a hard copy output of a text file should appear.

Actual result:
The printer dialog shows that the loading progress gets to 96% but does not reach 100%. The document is not entirely printed, from 75 pages only 72 got printed.
Can you confirm if this happens in other browsers, platforms, and Firefox versions?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
The document is entirely printed from Firefox 4.0.1 and Chrome 19.0.1084.52 m :

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120611 Firefox/15.0a2
On the latest Aurora build the Printing dialog gets stuck at 96% (I waited for 15 minutesex and it didn't reached 100%). Nt, when I canceled the printing process from the browser's Printing dialog window and  from the Printer's queue dialog window (Control Panel > Hardware and Sound > Devices and Printers) the printing started but only 72 pages out of 75 got printed. 
Attached a screenshot with the stuck Printing dialog.
Simona, can you please work on a regression range for this bug?

Comment 4

7 years ago
Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7e132eee5650
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110914 Firefox/9.0a1 ID:20110914103830
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c614dabf94e2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110914 Firefox/9.0a1 ID:20110914115129
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7e132eee5650&tochange=c614dabf94e2

Suspected:
fec42fae34a7	Adrian Johnson — Bug 454532. cairo: Print as Unicode. r=jrmuizel
Thanks Alice!
Version: 15 Branch → Trunk
Reproducible on WIn 7 32 bit, too. Moreover, canceling the progress freezes Firefox (only window resize works, but with painting issues).
Hardware: x86_64 → All
(In reply to Mihaela Velimiroviciu [QA] from comment #6)
> Reproducible on WIn 7 32 bit, too. Moreover, canceling the progress freezes
> Firefox (only window resize works, but with painting issues).

Used Firefox 15 beta 2 Built from http://hg.mozilla.org/releases/mozilla-beta/rev/c4a261f734bc
Duplicate of this bug: 747003
"Print to file" has the same result.

Comment 10

7 years ago
If disabling hardware acceleration fixes the problem it is a duplicate of bug 717178.
(In reply to Adrian Johnson from comment #10)
> If disabling hardware acceleration fixes the problem it is a duplicate of
> bug 717178.

I confirm.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 717178
You need to log in before you can comment on or make changes to this bug.